aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/bpftools/Makefile
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-03-01 01:07:45 -0800
committerDaniel Golle <daniel@makrotopia.org>2021-03-07 20:07:22 +0000
commit9e64e4ce26719ea81637b0e3d9754bd5190f0c21 (patch)
tree04dba553eb58a02abfb9c21411c40a4b6def4152 /package/network/utils/bpftools/Makefile
parent7e7218d1331d0b557b0e9a513aef5de584b6b1d2 (diff)
downloadupstream-9e64e4ce26719ea81637b0e3d9754bd5190f0c21.tar.gz
upstream-9e64e4ce26719ea81637b0e3d9754bd5190f0c21.tar.bz2
upstream-9e64e4ce26719ea81637b0e3d9754bd5190f0c21.zip
bpftools: fix libbpf pkgconfig file
The pkgconfig file hardcodes a host library directory which cannot be overridden by OpenWrt during builds. Use SED to fix this and potential include directory problems, as is done with several other packages. This fixes a strange issue intermittently seen building iproute2 on the oxnas target: iptables modules directory: /usr/lib/iptables libc has setns: yes SELinux support: no libbpf support: no libbpf version 0.3.0 is too low, please update it to at least 0.1.0 LIBBPF_FORCE=on set, but couldn't find a usable libbpf Fixes: 2f0d672088c3 ("bpftools: add utility and library packages supporting eBPF usage") Reported-by: Russell Senior <russell@personaltelco.net> Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/network/utils/bpftools/Makefile')
-rw-r--r--package/network/utils/bpftools/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/network/utils/bpftools/Makefile b/package/network/utils/bpftools/Makefile
index a466c82e9f..15bed2d89e 100644
--- a/package/network/utils/bpftools/Makefile
+++ b/package/network/utils/bpftools/Makefile
@@ -145,6 +145,10 @@ define Build/InstallDev/libbpf
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib$(LIB_SUFFIX)/pkgconfig/libbpf.pc \
$(1)/usr/lib/pkgconfig/
+ $(SED) 's,/usr/include,$$$${prefix}/include,g' \
+ $(1)/usr/lib/pkgconfig/libbpf.pc
+ $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' \
+ $(1)/usr/lib/pkgconfig/libbpf.pc
endef
ifeq ($(BUILD_VARIANT),lib)