aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 10:19:33 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 10:19:33 +0000
commit874e0061cec6b2a32d259077fb1789c00bf07833 (patch)
treebd325bd6708bf1a873f293c3ec351653c20b02f9 /package/network/services
parent9b22f6f735e786f1ba7a06a859ce6ddbead4dbe9 (diff)
downloadupstream-874e0061cec6b2a32d259077fb1789c00bf07833.tar.gz
upstream-874e0061cec6b2a32d259077fb1789c00bf07833.tar.bz2
upstream-874e0061cec6b2a32d259077fb1789c00bf07833.zip
uhttpd: update to latest git revision
adds URL alias support Signed-off-by: John Crispin <blogic@openwrt.org> BAckport of r47206 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47231 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services')
-rw-r--r--package/network/services/uhttpd/Makefile4
-rwxr-xr-xpackage/network/services/uhttpd/files/uhttpd.init5
2 files changed, 7 insertions, 2 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index a9a535aee8..253da44920 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2015-10-08
+PKG_VERSION:=2015-10-17
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=7ed2edc40dd6d0171266f3bfbc96466e1d25e3cd
+PKG_SOURCE_VERSION:=3614ae6eb7b6101fa5d0f14ff0d3a6eb4970c3da
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_LICENSE:=ISC
diff --git a/package/network/services/uhttpd/files/uhttpd.init b/package/network/services/uhttpd/files/uhttpd.init
index a3e09c44e7..7f0d4027f8 100755
--- a/package/network/services/uhttpd/files/uhttpd.init
+++ b/package/network/services/uhttpd/files/uhttpd.init
@@ -94,6 +94,11 @@ start_instance()
append_bool "$cfg" no_dirlists "-D" 0
append_bool "$cfg" rfc1918_filter "-R" 0
+ config_get alias_list "$cfg" alias
+ for alias in $alias_list; do
+ procd_append_param command -y "$alias"
+ done
+
config_get http "$cfg" listen_http
for listen in $http; do
procd_append_param command -p "$listen"