aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-11 13:15:24 +0100
committerFelix Fietkau <nbd@nbd.name>2017-11-11 13:20:39 +0100
commit12f9305c12d0c6c274a61fc577a36be93a634de4 (patch)
tree6ec73df2b42a11588e5203b79bb7f0505da60614 /package/network/services
parentf7186599ce72bfcc6f6442c9f43fa65f76d68206 (diff)
downloadupstream-12f9305c12d0c6c274a61fc577a36be93a634de4.tar.gz
upstream-12f9305c12d0c6c274a61fc577a36be93a634de4.tar.bz2
upstream-12f9305c12d0c6c274a61fc577a36be93a634de4.zip
wireguard: fix portability issue
Check if the compiler defines __linux__, instead of assuming that the host OS is the same as the target OS. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/services')
-rw-r--r--package/network/services/wireguard/patches/100-portability.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/network/services/wireguard/patches/100-portability.patch b/package/network/services/wireguard/patches/100-portability.patch
new file mode 100644
index 0000000000..e55c922073
--- /dev/null
+++ b/package/network/services/wireguard/patches/100-portability.patch
@@ -0,0 +1,18 @@
+tools: fix portability issue
+
+Check if the compiler defines __linux__, instead of assuming that the
+host OS is the same as the target OS.
+
+Signed-off-by: Felix Fietkau <nbd@nbd.name>
+---
+--- a/src/tools/Makefile
++++ b/src/tools/Makefile
+@@ -39,7 +39,7 @@ CFLAGS += -DRUNSTATEDIR="\"$(RUNSTATEDIR
+ ifeq ($(DEBUG_TOOLS),y)
+ CFLAGS += -g
+ endif
+-ifeq ($(shell uname -s),Linux)
++ifeq ($(strip $(shell echo __linux__ | $(CC) -E - | grep -v '^\#')),1)
+ LIBMNL_CFLAGS := $(shell $(PKG_CONFIG) --cflags libmnl 2>/dev/null)
+ LIBMNL_LDLIBS := $(shell $(PKG_CONFIG) --libs libmnl 2>/dev/null || echo -lmnl)
+ CFLAGS += $(LIBMNL_CFLAGS)