aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/odhcpd/Makefile
diff options
context:
space:
mode:
authorStijn Segers <foss@volatilesystems.org>2020-09-20 23:03:32 +0200
committerHans Dedecker <dedeckeh@gmail.com>2020-09-21 20:59:40 +0200
commitec80139629f1087d67f5956caf92b2320c5b54e9 (patch)
treead931d9a52edc4974b7c0441af36231881568e11 /package/network/services/odhcpd/Makefile
parent236e79abb72e22c6e87110a7b0e5288cf3b48efa (diff)
downloadupstream-ec80139629f1087d67f5956caf92b2320c5b54e9.tar.gz
upstream-ec80139629f1087d67f5956caf92b2320c5b54e9.tar.bz2
upstream-ec80139629f1087d67f5956caf92b2320c5b54e9.zip
odhcpd: number UCI defaults script
UCI defaults scripts are supposed to be numbered, but odhcpd's lacked numbering, which turned out to mess up my custom scripts numbered 9[0-9]_*. The idea is to have high number (custom) scripts executed last. Jow confirmed numbering is the default case, not the exception (thanks). Signed-off-by: Stijn Segers <foss@volatilesystems.org>
Diffstat (limited to 'package/network/services/odhcpd/Makefile')
-rw-r--r--package/network/services/odhcpd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/services/odhcpd/Makefile b/package/network/services/odhcpd/Makefile
index d3e131caec..62dd53774d 100644
--- a/package/network/services/odhcpd/Makefile
+++ b/package/network/services/odhcpd/Makefile
@@ -100,7 +100,7 @@ define Package/odhcpd/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/odhcpd.init $(1)/etc/init.d/odhcpd
$(INSTALL_DIR) $(1)/etc/uci-defaults
- $(INSTALL_BIN) ./files/odhcpd.defaults $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/odhcpd.defaults $(1)/etc/uci-defaults/15_odhcpd
endef
Package/odhcpd-ipv6only/install = $(Package/odhcpd/install)