aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/lldpd/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-01-05 13:05:57 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2017-01-10 13:02:00 +0100
commit046606a05eaece636dae1565fd1445b02a37d940 (patch)
treefeea24eaf40954f1e6282cbb4f1b34f92ce30fe5 /package/network/services/lldpd/Makefile
parent0d3dc169316616103dc30252c9aae4de27ab3d50 (diff)
downloadupstream-046606a05eaece636dae1565fd1445b02a37d940.tar.gz
upstream-046606a05eaece636dae1565fd1445b02a37d940.tar.bz2
upstream-046606a05eaece636dae1565fd1445b02a37d940.zip
lldpd: add Net-SNMP AgentX support
Enabling this makes it possible to query LLDP neighbors via SNMP. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Acked-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/network/services/lldpd/Makefile')
-rw-r--r--package/network/services/lldpd/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 3579e53e02..74169a1c4c 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -31,7 +31,7 @@ define Package/lldpd
SUBMENU:=Routing and Redirection
TITLE:=Link Layer Discovery Protocol daemon
URL:=https://github.com/vincentbernat/lldpd/wiki
- DEPENDS:=+libevent2 +USE_GLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
+ DEPENDS:=+libevent2 +USE_GLIBC:libbsd +LLDPD_WITH_JSON:libjson-c +LLDPD_WITH_SNMP:libnetsnmp
USERID:=lldp=121:lldp=129
MENU:=1
endef
@@ -78,6 +78,9 @@ endif
ifneq ($(CONFIG_LLDPD_WITH_SONMP),y)
sed -i -e '/sonmp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
endif
+ifneq ($(CONFIG_LLDPD_WITH_SNMP),y)
+ sed -i -e '/agentxsocket/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
endef
define Package/lldpd/conffiles
@@ -103,7 +106,8 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
$(if $(CONFIG_LLDPD_WITH_CUSTOM),,--disable-custom) \
$(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
- $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no)
+ $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no) \
+ $(if $(CONFIG_LLDPD_WITH_SNMP),--with-snmp,)
$(eval $(call BuildPackage,lldpd))