aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2020-11-02 10:35:20 +0000
committerDaniel Golle <daniel@makrotopia.org>2020-11-23 03:02:21 +0000
commitdd4e6a70f2f4eefab8a7dd663b881ba4f29bd5ba (patch)
tree714b64f69340fe468fe4d729f316a05f2a999a28 /package/network/services/hostapd
parent97ac290090a5c2120d4cd1e88823f9003a6f8484 (diff)
downloadupstream-dd4e6a70f2f4eefab8a7dd663b881ba4f29bd5ba.tar.gz
upstream-dd4e6a70f2f4eefab8a7dd663b881ba4f29bd5ba.tar.bz2
upstream-dd4e6a70f2f4eefab8a7dd663b881ba4f29bd5ba.zip
hostapd: enable the epoll-based event loop
Hostapd supports epoll() since 2014. Let's enable it for better performance. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'package/network/services/hostapd')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd-basic.config2
-rw-r--r--package/network/services/hostapd/files/hostapd-full.config2
-rw-r--r--package/network/services/hostapd/files/hostapd-mini.config2
-rw-r--r--package/network/services/hostapd/files/wpa_supplicant-basic.config2
-rw-r--r--package/network/services/hostapd/files/wpa_supplicant-full.config2
-rw-r--r--package/network/services/hostapd/files/wpa_supplicant-mini.config2
-rw-r--r--package/network/services/hostapd/files/wpa_supplicant-p2p.config2
8 files changed, 8 insertions, 8 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index e25cd20a2a..1e20b56200 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=16
+PKG_RELEASE:=17
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd-basic.config b/package/network/services/hostapd/files/hostapd-basic.config
index 19ea850f6b..947e2fa200 100644
--- a/package/network/services/hostapd/files/hostapd-basic.config
+++ b/package/network/services/hostapd/files/hostapd-basic.config
@@ -268,7 +268,7 @@ CONFIG_GETRANDOM=y
#CONFIG_ELOOP_POLL=y
# Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
# Should we use kqueue instead of select? Select is used by default.
#CONFIG_ELOOP_KQUEUE=y
diff --git a/package/network/services/hostapd/files/hostapd-full.config b/package/network/services/hostapd/files/hostapd-full.config
index fee4479dfa..df272e443a 100644
--- a/package/network/services/hostapd/files/hostapd-full.config
+++ b/package/network/services/hostapd/files/hostapd-full.config
@@ -268,7 +268,7 @@ CONFIG_GETRANDOM=y
#CONFIG_ELOOP_POLL=y
# Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
# Should we use kqueue instead of select? Select is used by default.
#CONFIG_ELOOP_KQUEUE=y
diff --git a/package/network/services/hostapd/files/hostapd-mini.config b/package/network/services/hostapd/files/hostapd-mini.config
index d9511441e6..b3050f7bbc 100644
--- a/package/network/services/hostapd/files/hostapd-mini.config
+++ b/package/network/services/hostapd/files/hostapd-mini.config
@@ -268,7 +268,7 @@ CONFIG_GETRANDOM=y
#CONFIG_ELOOP_POLL=y
# Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
# Should we use kqueue instead of select? Select is used by default.
#CONFIG_ELOOP_KQUEUE=y
diff --git a/package/network/services/hostapd/files/wpa_supplicant-basic.config b/package/network/services/hostapd/files/wpa_supplicant-basic.config
index db3f7c7a11..c550b37b21 100644
--- a/package/network/services/hostapd/files/wpa_supplicant-basic.config
+++ b/package/network/services/hostapd/files/wpa_supplicant-basic.config
@@ -290,7 +290,7 @@ CONFIG_NO_CONFIG_WRITE=y
#CONFIG_ELOOP_POLL=y
# Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
# Should we use kqueue instead of select? Select is used by default.
#CONFIG_ELOOP_KQUEUE=y
diff --git a/package/network/services/hostapd/files/wpa_supplicant-full.config b/package/network/services/hostapd/files/wpa_supplicant-full.config
index 4dd3e550a6..b3e85d073d 100644
--- a/package/network/services/hostapd/files/wpa_supplicant-full.config
+++ b/package/network/services/hostapd/files/wpa_supplicant-full.config
@@ -290,7 +290,7 @@ CONFIG_BACKEND=file
#CONFIG_ELOOP_POLL=y
# Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
# Should we use kqueue instead of select? Select is used by default.
#CONFIG_ELOOP_KQUEUE=y
diff --git a/package/network/services/hostapd/files/wpa_supplicant-mini.config b/package/network/services/hostapd/files/wpa_supplicant-mini.config
index c1e0141edd..9eb1111e52 100644
--- a/package/network/services/hostapd/files/wpa_supplicant-mini.config
+++ b/package/network/services/hostapd/files/wpa_supplicant-mini.config
@@ -290,7 +290,7 @@ CONFIG_NO_CONFIG_WRITE=y
#CONFIG_ELOOP_POLL=y
# Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
# Should we use kqueue instead of select? Select is used by default.
#CONFIG_ELOOP_KQUEUE=y
diff --git a/package/network/services/hostapd/files/wpa_supplicant-p2p.config b/package/network/services/hostapd/files/wpa_supplicant-p2p.config
index 5156048284..b00847a256 100644
--- a/package/network/services/hostapd/files/wpa_supplicant-p2p.config
+++ b/package/network/services/hostapd/files/wpa_supplicant-p2p.config
@@ -290,7 +290,7 @@ CONFIG_BACKEND=file
#CONFIG_ELOOP_POLL=y
# Should we use epoll instead of select? Select is used by default.
-#CONFIG_ELOOP_EPOLL=y
+CONFIG_ELOOP_EPOLL=y
# Should we use kqueue instead of select? Select is used by default.
#CONFIG_ELOOP_KQUEUE=y