aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-14 06:51:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-14 06:51:10 +0000
commit42a3d7811f7cb3ec69f35e0e157364f511c439bd (patch)
tree13f89b41dfa61eb61eba7072d26bf5c61091497e /package/network/services/hostapd/Makefile
parent714f7080cf02ea7a865c55f9b6f9c75c668e827f (diff)
downloadupstream-42a3d7811f7cb3ec69f35e0e157364f511c439bd.tar.gz
upstream-42a3d7811f7cb3ec69f35e0e157364f511c439bd.tar.bz2
upstream-42a3d7811f7cb3ec69f35e0e157364f511c439bd.zip
mac80211/hostapd: rework 802.11w driver support selection, do not hardcode drivers in hostapd makefile
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46903
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index c39b6b410d..edcfd1ba37 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -71,7 +71,7 @@ DRIVER_MAKEOPTS= \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
ifeq ($(LOCAL_VARIANT),full)
- DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+ DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_DRIVER_11W_SUPPORT)
endif
ifneq ($(LOCAL_TYPE),hostapd)