aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dropbear/patches/901-bundled-libs-cflags.patch
diff options
context:
space:
mode:
authorKonstantin Demin <rockdrilla@gmail.com>2020-06-21 15:36:47 +0300
committerHans Dedecker <dedeckeh@gmail.com>2020-06-21 21:33:23 +0200
commit29e170dbaac0091d09ae52157cd2f1f26a9c8ca4 (patch)
treea9e048b0bb284763769bc589a53c5db319de6d74 /package/network/services/dropbear/patches/901-bundled-libs-cflags.patch
parent340de1d1545f6da3f21b06a23bb8288da6d992be (diff)
downloadupstream-29e170dbaac0091d09ae52157cd2f1f26a9c8ca4.tar.gz
upstream-29e170dbaac0091d09ae52157cd2f1f26a9c8ca4.tar.bz2
upstream-29e170dbaac0091d09ae52157cd2f1f26a9c8ca4.zip
dropbear: bump to 2020.79
- drop patches (applied upstream): * 010-backport-change-address-logging.patch * 020-backport-ed25519-support.patch * 021-backport-chacha20-poly1305-support.patch - backport patches: * 010-backport-disable-toom-and-karatsuba.patch: reduce dropbear binary size (about ~8Kb). - refresh patches. - don't bother anymore with following config options because they are disabled in upstream too: * DROPBEAR_3DES * DROPBEAR_ENABLE_CBC_MODE * DROPBEAR_SHA1_96_HMAC - explicitly disable DO_MOTD as it was before commit a1099ed: upstream has (accidentally) switched it to 0 in release 2019.77, but reverted back in release 2020.79. Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
Diffstat (limited to 'package/network/services/dropbear/patches/901-bundled-libs-cflags.patch')
-rw-r--r--package/network/services/dropbear/patches/901-bundled-libs-cflags.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/package/network/services/dropbear/patches/901-bundled-libs-cflags.patch b/package/network/services/dropbear/patches/901-bundled-libs-cflags.patch
index 033aee3a06..2432b4ef72 100644
--- a/package/network/services/dropbear/patches/901-bundled-libs-cflags.patch
+++ b/package/network/services/dropbear/patches/901-bundled-libs-cflags.patch
@@ -1,6 +1,6 @@
--- a/libtomcrypt/makefile_include.mk
+++ b/libtomcrypt/makefile_include.mk
-@@ -75,6 +75,13 @@ endif
+@@ -94,6 +94,13 @@ endif
LTC_CFLAGS += -Wno-type-limits
@@ -14,7 +14,7 @@
ifdef LTC_DEBUG
$(info Debug build)
# compile for DEBUGGING (required for ccmalloc checking!!!)
-@@ -102,6 +109,9 @@ endif
+@@ -121,6 +128,9 @@ endif
endif # COMPILE_SMALL
endif # COMPILE_DEBUG
@@ -26,8 +26,8 @@
LTC_CFLAGS += -Wno-typedef-redefinition -Wno-tautological-compare -Wno-builtin-requires-header -Wno-missing-field-initializers
--- a/libtommath/makefile_include.mk
+++ b/libtommath/makefile_include.mk
-@@ -37,6 +37,9 @@ CFLAGS += -Wsystem-headers -Wdeclaration
- CFLAGS += -Wstrict-prototypes -Wpointer-arith
+@@ -70,6 +70,9 @@ else
+ LTM_CFLAGS += -Wsystem-headers
endif
+ifndef OPENWRT_BUILD
@@ -35,14 +35,14 @@
+
ifdef COMPILE_DEBUG
#debug
- CFLAGS += -g3
-@@ -58,6 +61,9 @@ endif
+ LTM_CFLAGS += -g3
+@@ -90,6 +93,9 @@ endif
+
endif # COMPILE_SIZE
- endif # COMPILE_DEBUG
+ ### ! OPENWRT_BUILD
+endif
+
ifneq ($(findstring clang,$(CC)),)
- CFLAGS += -Wno-typedef-redefinition -Wno-tautological-compare -Wno-builtin-requires-header
+ LTM_CFLAGS += -Wno-typedef-redefinition -Wno-tautological-compare -Wno-builtin-requires-header
endif