aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-02-08 18:21:12 +0100
committerHans Dedecker <dedeckeh@gmail.com>2018-02-08 18:29:37 +0100
commit787326b43e332b378899205294b1d92ea77a45d4 (patch)
tree64eae343b83988b0ffdcea17dd1fdedf484574b6 /package/network/ipv6
parent30d34358a984603fd5bfea41630501303c840e2c (diff)
downloadupstream-787326b43e332b378899205294b1d92ea77a45d4.tar.gz
upstream-787326b43e332b378899205294b1d92ea77a45d4.tar.bz2
upstream-787326b43e332b378899205294b1d92ea77a45d4.zip
odhcp6c: fix appending of emtpy sendopt value (FS#1336)
Don't append an empty sendopts value as odhcp6c bails out immediately on an empty -x option triggering an infinite start loop of odhcp6c Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile2
-rwxr-xr-xpackage/network/ipv6/odhcp6c/files/dhcpv6.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index ac793f1ad2..9989f80f1a 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_RELEASE:=7
+PKG_RELEASE:=8
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcp6c.git
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.sh b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
index bc7f01d322..5c2ee6b988 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.sh
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
@@ -77,7 +77,7 @@ proto_dhcpv6_setup() {
sendopts_cb() {
local val="$1"
- append opts "-x$val"
+ [ -n "$val" ] && append opts "-x$val"
}
json_for_each_item sendopts_cb sendopts