aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/thc-ipv6/patches
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-10-11 21:57:56 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-10-11 21:57:56 +0000
commitf248332d523680d0b4dd91c3f78fa5d449456331 (patch)
tree016b56849636294dfcdba60457c013513984cfbe /package/network/ipv6/thc-ipv6/patches
parentf5d12a126d0b012e899975ffa4fb1291e6475727 (diff)
downloadupstream-f248332d523680d0b4dd91c3f78fa5d449456331.tar.gz
upstream-f248332d523680d0b4dd91c3f78fa5d449456331.tar.bz2
upstream-f248332d523680d0b4dd91c3f78fa5d449456331.zip
thc-ipv6: update to v2.0, package all available utilities
SVN-Revision: 33728
Diffstat (limited to 'package/network/ipv6/thc-ipv6/patches')
-rw-r--r--package/network/ipv6/thc-ipv6/patches/100-no-ssl.patch11
-rw-r--r--package/network/ipv6/thc-ipv6/patches/100-optional-openssl.patch93
2 files changed, 11 insertions, 93 deletions
diff --git a/package/network/ipv6/thc-ipv6/patches/100-no-ssl.patch b/package/network/ipv6/thc-ipv6/patches/100-no-ssl.patch
new file mode 100644
index 0000000000..5f87bcd350
--- /dev/null
+++ b/package/network/ipv6/thc-ipv6/patches/100-no-ssl.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ CC=gcc
+ #CFLAGS?=-Wall -ggdb
+ CFLAGS?=-O2
+-LDFLAGS+=-lpcap -lssl -lcrypto
++LDFLAGS+=-lpcap
+ PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_router26 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 thcping6 covert_send6 covert_send6d
+ LIBS=thc-ipv6-lib.o
+
diff --git a/package/network/ipv6/thc-ipv6/patches/100-optional-openssl.patch b/package/network/ipv6/thc-ipv6/patches/100-optional-openssl.patch
deleted file mode 100644
index 96f6ceb707..0000000000
--- a/package/network/ipv6/thc-ipv6/patches/100-optional-openssl.patch
+++ /dev/null
@@ -1,93 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,8 +1,8 @@
- CC=gcc
- #OPT=-Wall -ggdb
--OPT=-O2
--LIB=-lpcap -lssl -lcrypto
--PROGRAM=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_mld6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 test_implementation6 sendpees6
-+OPT=-O2 $(if $(USE_SSL),-DUSE_SSL,)
-+LIB=-lpcap $(if $(USE_SSL),-lssl -lcrypto,)
-+PROGRAM=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_mld6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 test_implementation6 $(if $(USE_SSL),sendpees6,)
-
- all: thc-ipv6-lib.o $(PROGRAM)
-
---- a/thc-ipv6-lib.c
-+++ b/thc-ipv6-lib.c
-@@ -37,8 +37,10 @@
- #include <pcap.h>
- #include "thc-ipv6.h"
- /* libssl */
-+#ifdef USE_SSL
- #include <openssl/evp.h>
- #include <openssl/sha.h>
-+#endif
-
-
-
-@@ -1507,7 +1509,7 @@
- * 2006/07
- */
-
--
-+#ifdef USE_SSL
- thc_key_t *thc_generate_key(int key_len)
- {
- thc_key_t *key;
-@@ -1598,6 +1600,7 @@
-
- return cga_hdr;
- }
-+#endif
-
- thc_timestamp_hdr *generate_timestamp(void)
- {
-@@ -1632,6 +1635,7 @@
- return nonce;
- }
-
-+#ifdef USE_SSL
- thc_rsa_hdr *thc_generate_rsa(char *data2sign, int data2sign_len, thc_cga_hdr *cga_hdr, thc_key_t *key)
- {
- thc_rsa_hdr *rsa_hdr;
-@@ -1827,3 +1831,4 @@
-
- return 0;
- }
-+#endif
---- a/thc-ipv6.h
-+++ b/thc-ipv6.h
-@@ -10,7 +10,9 @@
- #define _THC_IPV6_H
-
- #include <pcap.h>
-+#ifdef USE_SSL
- #include <openssl/rsa.h>
-+#endif
-
- #define VERSION "v0.7"
- #define AUTHOR "van Hauser / THC <vh@thc.org>"
-@@ -228,10 +230,12 @@
- char *pad;
- } thc_rsa_hdr;
-
-+#ifdef USE_SSL
- typedef struct {
- RSA *rsa;
- int len;
- } thc_key_t;
-+#endif
-
- typedef struct {
- unsigned char *data;
-@@ -239,8 +243,10 @@
- int len;
- } opt_t;
-
-+#ifdef USE_SSL
- extern thc_key_t *thc_generate_key(int key_len);
- extern thc_cga_hdr *thc_generate_cga(unsigned char *prefix, thc_key_t *key, unsigned char **cga);
-+#endif
-
- #endif
-