aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/odhcp6c
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-02-05 09:57:48 +0100
committerHans Dedecker <dedeckeh@gmail.com>2018-02-08 12:19:48 +0100
commitd8acbb86a1002eb711bf624d9097057548723222 (patch)
treefdb94e768ffde53034dcb84b217572f35749e1e9 /package/network/ipv6/odhcp6c
parent112f0469c4f1b6a6f263f9cef93bbf210917042a (diff)
downloadupstream-d8acbb86a1002eb711bf624d9097057548723222.tar.gz
upstream-d8acbb86a1002eb711bf624d9097057548723222.tar.bz2
upstream-d8acbb86a1002eb711bf624d9097057548723222.zip
odhcp6c: change sendopts option into list
Commit a26045049b added support for sendopts as a string; since multiple sendopts values can be specified it makes more sense to model it as a list of strings. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/ipv6/odhcp6c')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile2
-rwxr-xr-xpackage/network/ipv6/odhcp6c/files/dhcpv6.sh14
2 files changed, 9 insertions, 7 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 674d12fc6e..ac793f1ad2 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcp6c.git
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.sh b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
index 82b329de9b..bc7f01d322 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.sh
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.sh
@@ -27,7 +27,7 @@ proto_dhcpv6_init_config() {
proto_config_add_string 'ifaceid:ip6addr'
proto_config_add_string "userclass"
proto_config_add_string "vendorclass"
- proto_config_add_string "sendopts"
+ proto_config_add_array "sendopts:list(string)"
proto_config_add_boolean delegate
proto_config_add_int "soltimeout"
proto_config_add_boolean fakeroutes
@@ -41,8 +41,7 @@ proto_dhcpv6_setup() {
local iface="$2"
local reqaddress reqprefix clientid reqopts defaultreqopts noslaaconly forceprefix extendprefix norelease ip6prefix iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass sendopts delegate zone_dslite zone_map zone_464xlat zone soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
- json_get_vars reqaddress reqprefix clientid reqopts defaultreqopts noslaaconly forceprefix extendprefix norelease ip6prefix iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass sendopts delegate zone_dslite zone_map zone_464xlat zone soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
-
+ json_get_vars reqaddress reqprefix clientid reqopts defaultreqopts noslaaconly forceprefix extendprefix norelease ip6prefix iface_dslite iface_map iface_464xlat ifaceid userclass vendorclass delegate zone_dslite zone_map zone_464xlat zone soltimeout fakeroutes sourcefilter keep_ra_dnslifetime ra_holdoff
# Configure
local opts=""
@@ -76,9 +75,12 @@ proto_dhcpv6_setup() {
append opts "-r$opt"
done
- for opt in $sendopts; do
- append opts "-x$opt"
- done
+ sendopts_cb() {
+ local val="$1"
+ append opts "-x$val"
+ }
+
+ json_for_each_item sendopts_cb sendopts
append opts "-t${soltimeout:-120}"