aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/odhcp6c
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2021-03-09 22:16:05 +0000
committerHans Dedecker <dedeckeh@gmail.com>2021-03-10 20:16:06 +0100
commitb4f3d93b5f3d82142e6af51486f4f99a57f33e29 (patch)
treedbc37bda009caaadf861b0179abf0243311ba5c3 /package/network/ipv6/odhcp6c
parentfc5b101c06928884d2b0c42b11bf917d29538971 (diff)
downloadupstream-b4f3d93b5f3d82142e6af51486f4f99a57f33e29.tar.gz
upstream-b4f3d93b5f3d82142e6af51486f4f99a57f33e29.tar.bz2
upstream-b4f3d93b5f3d82142e6af51486f4f99a57f33e29.zip
odhcp6c: add a odhcp6c.user placeholder script
Document the existence of this feature. This allows the user to execute a script at each DHCPv6 event. This is useful, for example, as an ad-hoc way to update a DDNS entry when (and only when) required. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'package/network/ipv6/odhcp6c')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile8
-rw-r--r--package/network/ipv6/odhcp6c/files/odhcp6c.user1
2 files changed, 8 insertions, 1 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index c9eaaedb19..b3b2ea11fb 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_RELEASE:=16
+PKG_RELEASE:=17
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcp6c.git
@@ -42,12 +42,18 @@ define Package/odhcp6c/config
default 0
endef
+define Package/odhcp6c/conffiles
+/etc/odhcp6c.user
+endef
+
define Package/odhcp6c/install
$(INSTALL_DIR) $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/odhcp6c $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/lib/netifd/proto
$(INSTALL_BIN) ./files/dhcpv6.sh $(1)/lib/netifd/proto/dhcpv6.sh
$(INSTALL_BIN) ./files/dhcpv6.script $(1)/lib/netifd/
+ $(INSTALL_DIR) $(1)/etc/
+ $(INSTALL_CONF) ./files/odhcp6c.user $(1)/etc/
endef
$(eval $(call BuildPackage,odhcp6c))
diff --git a/package/network/ipv6/odhcp6c/files/odhcp6c.user b/package/network/ipv6/odhcp6c/files/odhcp6c.user
new file mode 100644
index 0000000000..f15a1b1761
--- /dev/null
+++ b/package/network/ipv6/odhcp6c/files/odhcp6c.user
@@ -0,0 +1 @@
+# This script is sourced by odhcp6c's dhcpv6.script at every DHCPv6 event.