aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/odhcp6c
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2016-12-16 18:35:03 +0100
committerHans Dedecker <dedeckeh@gmail.com>2016-12-16 18:49:56 +0100
commit7d760284a73675e5675d18ecb2d2130d117aaf4e (patch)
tree4224fce9c727920a0f3e317b9a8851c987cd804b /package/network/ipv6/odhcp6c
parent44ac4adb34dc35d2f294ab3340e7d09edea0b076 (diff)
downloadupstream-7d760284a73675e5675d18ecb2d2130d117aaf4e.tar.gz
upstream-7d760284a73675e5675d18ecb2d2130d117aaf4e.tar.bz2
upstream-7d760284a73675e5675d18ecb2d2130d117aaf4e.zip
odhcp6c: Pass parameters to user dhcpv6 script
Pass all the parameters like device, dhcpv6 state to user script Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/ipv6/odhcp6c')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile4
-rwxr-xr-xpackage/network/ipv6/odhcp6c/files/dhcpv6.script2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 9b50e21e4d..c78198b2e7 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2016-06-30
+PKG_VERSION:=2016-12-16
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -16,7 +16,7 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://github.com/sbyx/odhcp6c.git
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=7533a6243dc3ac5a747cf6ccbc4d0539dafd3e07
-PKG_MIRROR_MD5SUM:=faaa26d09039c3133626f67a01b07b9922fea105e6566c44e78350fce51fa2b8
+PKG_MIRROR_MD5SUM:=fa9225cd0d9e822b2ff06220b60687710c424e136c078ac1224818fda0ccfb6d
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.script b/package/network/ipv6/odhcp6c/files/dhcpv6.script
index 46980cb57d..1bb5e771b6 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.script
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.script
@@ -214,6 +214,6 @@ case "$2" in
esac
# user rules
-[ -f /etc/odhcp6c.user ] && . /etc/odhcp6c.user
+[ -f /etc/odhcp6c.user ] && . /etc/odhcp6c.user "@"
exit 0