aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-02-12 14:10:12 -0800
committerFlorian Fainelli <f.fainelli@gmail.com>2017-03-01 17:19:51 -0800
commitfe8618a8fe0db1bc8f343c0f75082ff96e9991ab (patch)
tree8f9a453eb501fb507ac4180ce63bab5df513e14d /package/network/config
parent306ee6436170d4c3c0c677653e9a20a8ee116cf7 (diff)
downloadupstream-fe8618a8fe0db1bc8f343c0f75082ff96e9991ab.tar.gz
upstream-fe8618a8fe0db1bc8f343c0f75082ff96e9991ab.tar.bz2
upstream-fe8618a8fe0db1bc8f343c0f75082ff96e9991ab.zip
swconfig: Link with libubox
Fixes linking failures observed with external toolchains: /home/florian/dev/toolchains/stbgcc-4.8-1.5/bin/../lib/gcc/mipsel-linux-gnu/4.8.5/../../../../mipsel-linux-gnu/bin/ld: warning: libubox.so, needed by /home/florian/dev/openwrt/trunk/staging_dir/target-mipsel-unknown-linux-gnu_glibc/usr/lib/libuci.so, not found (try using -rpath or -rpath-link) /home/florian/dev/openwrt/trunk/staging_dir/target-mipsel-unknown-linux-gnu_glibc/usr/lib/libuci.so: undefined reference to `blobmsg_open_nested' /home/florian/dev/openwrt/trunk/staging_dir/target-mipsel-unknown-linux-gnu_glibc/usr/lib/libuci.so: undefined reference to `blobmsg_parse' /home/florian/dev/openwrt/trunk/staging_dir/target-mipsel-unknown-linux-gnu_glibc/usr/lib/libuci.so: undefined reference to `blob_nest_end' /home/florian/dev/openwrt/trunk/staging_dir/target-mipsel-unknown-linux-gnu_glibc/usr/lib/libuci.so: undefined reference to `blobmsg_add_field' Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/swconfig/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/config/swconfig/Makefile b/package/network/config/swconfig/Makefile
index e4a00d6d63..e457ce4882 100644
--- a/package/network/config/swconfig/Makefile
+++ b/package/network/config/swconfig/Makefile
@@ -34,7 +34,7 @@ define Build/Compile
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
- LIBS="$(TARGET_LDFLAGS) -lnl-tiny -lm -luci"
+ LIBS="$(TARGET_LDFLAGS) -lnl-tiny -lm -luci -lubox"
endef
define Build/InstallDev