aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-05-21 12:58:36 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-05-21 12:58:36 +0000
commit9b6c31d4ccc939777ec54ea32daceec604c78e1a (patch)
treecad4f522e2fcee99517e488f0ac400d635bd86bd /package/network/config
parent8df6cd005ce53a195d6f401d7fe10b9faab0e3dd (diff)
downloadupstream-9b6c31d4ccc939777ec54ea32daceec604c78e1a.tar.gz
upstream-9b6c31d4ccc939777ec54ea32daceec604c78e1a.tar.bz2
upstream-9b6c31d4ccc939777ec54ea32daceec604c78e1a.zip
firewall3: move libext*.a copying to compile phase
SVN-Revision: 36684
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/firewall3/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/config/firewall3/Makefile b/package/network/config/firewall3/Makefile
index 1ab4eaa472..5ddc792d1d 100644
--- a/package/network/config/firewall3/Makefile
+++ b/package/network/config/firewall3/Makefile
@@ -39,11 +39,11 @@ define Package/firewall3/conffiles
/etc/firewall.user
endef
-define Build/Prepare
- $(call Build/Prepare/Default)
+define Build/Compile
$(CP) $(lastword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/extensions/libext.a)) $(PKG_BUILD_DIR)/libext.a
$(CP) $(lastword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/extensions/libext4.a)) $(PKG_BUILD_DIR)/libext4.a
$(CP) $(lastword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/extensions/libext6.a)) $(PKG_BUILD_DIR)/libext6.a
+ $(call Build/Compile/Default)
endef
TARGET_CFLAGS += -ffunction-sections -fdata-sections