aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorAlin Nastac <alin.nastac@technicolor.com>2021-03-01 09:51:31 +0100
committerHans Dedecker <dedeckeh@gmail.com>2021-03-13 20:59:22 +0100
commit8704d138df5e7a30fb084a5450b07460d128a15a (patch)
tree0c506acebc43f2ab755b85372adbc3ec83b92a29 /package/network/config
parent65ca980b4872ee43157c6621896e84e817c9aeab (diff)
downloadupstream-8704d138df5e7a30fb084a5450b07460d128a15a.tar.gz
upstream-8704d138df5e7a30fb084a5450b07460d128a15a.tar.bz2
upstream-8704d138df5e7a30fb084a5450b07460d128a15a.zip
xfrm: simplify the check for necessary kernel support
[ -d /sys/module/xfrm_interface ] is enough to check if CONFIG_XFRM_INTERFACE support was enabled in kernel. Signed-off-by: Alin Nastac <alin.nastac@technicolor.com>
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/xfrm/Makefile2
-rwxr-xr-xpackage/network/config/xfrm/files/xfrm.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/config/xfrm/Makefile b/package/network/config/xfrm/Makefile
index bcee89f82c..777f20c77c 100644
--- a/package/network/config/xfrm/Makefile
+++ b/package/network/config/xfrm/Makefile
@@ -2,7 +2,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=xfrm
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/xfrm/files/xfrm.sh b/package/network/config/xfrm/files/xfrm.sh
index ca7c3380e6..bdebd4b9c3 100755
--- a/package/network/config/xfrm/files/xfrm.sh
+++ b/package/network/config/xfrm/files/xfrm.sh
@@ -68,5 +68,5 @@ proto_xfrm_init_config() {
[ -n "$INCLUDE_ONLY" ] || {
- [ -f /lib/modules/$(uname -r)/xfrm_interface.ko -o -d /sys/module/xfrm_interface ] && add_protocol xfrm
+ [ -d /sys/module/xfrm_interface ] && add_protocol xfrm
}