aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/xfrm/Makefile
diff options
context:
space:
mode:
authorAndré Valentin <avalentin@marcant.net>2019-06-08 13:48:08 +0200
committerHans Dedecker <dedeckeh@gmail.com>2019-06-10 10:07:24 +0200
commit452d88e8f798c550151cd1e1d204a528fb00db08 (patch)
treee39de1ce23fafd86446fb07a3df01552e0bad426 /package/network/config/xfrm/Makefile
parentcc092a285afa419711024fc72884e49d4983e14a (diff)
downloadupstream-452d88e8f798c550151cd1e1d204a528fb00db08.tar.gz
upstream-452d88e8f798c550151cd1e1d204a528fb00db08.tar.bz2
upstream-452d88e8f798c550151cd1e1d204a528fb00db08.zip
config: add xfrm interface support scripts
This package adds scripts for xfrm interfaces support. Example configuration via /etc/config/network: config interface 'xfrm0' option proto 'xfrm' option mtu '1300' option zone 'VPN' option tunlink 'wan' option ifid 30 config interface 'xfrm0_static' option proto 'static' option ifname '@xfrm0' option ip6addr 'fe80::1/64' option ipaddr '10.0.0.1/30' Now set in strongswan IPsec policy: if_id_in = 30 if_id_out = 30 Signed-off-by: André Valentin <avalentin@marcant.net>
Diffstat (limited to 'package/network/config/xfrm/Makefile')
-rw-r--r--package/network/config/xfrm/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/package/network/config/xfrm/Makefile b/package/network/config/xfrm/Makefile
new file mode 100644
index 0000000000..efc90cf318
--- /dev/null
+++ b/package/network/config/xfrm/Makefile
@@ -0,0 +1,38 @@
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xfrm
+PKG_VERSION:=1
+PKG_RELEASE:=1
+PKG_LICENSE:=GPL-2.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/xfrm/Default
+ SECTION:=net
+ CATEGORY:=Network
+ MAINTAINER:=Andre Valentin <avalentin@marcant.net>
+endef
+
+define Package/xfrm
+$(call Package/xfrm/Default)
+ TITLE:=XFRM IPsec Tunnel Interface config support
+ DEPENDS:=+kmod-xfrm-interface
+endef
+
+define Package/xfrm/description
+ XFRM IPsec Tunnel Interface config support (IPv4 and IPv6) in /etc/config/network.
+endef
+
+define Build/Compile
+endef
+
+define Build/Configure
+endef
+
+define Package/xfrm/install
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/xfrm.sh $(1)/lib/netifd/proto/xfrm.sh
+endef
+
+$(eval $(call BuildPackage,xfrm))