aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/vti
diff options
context:
space:
mode:
authorAlin Nastac <alin.nastac@technicolor.com>2021-03-01 09:49:43 +0100
committerHans Dedecker <dedeckeh@gmail.com>2021-03-13 20:59:11 +0100
commit65ca980b4872ee43157c6621896e84e817c9aeab (patch)
tree8374e739d924489334c954dfb7e65c84828bfa51 /package/network/config/vti
parent8a35ebe375d1c27e55dd2cb8c14f25440bc48821 (diff)
downloadupstream-65ca980b4872ee43157c6621896e84e817c9aeab.tar.gz
upstream-65ca980b4872ee43157c6621896e84e817c9aeab.tar.bz2
upstream-65ca980b4872ee43157c6621896e84e817c9aeab.zip
vti: use alternative way to check if kernel support is enabled
When necessary support is built in kernel, vti protocol support is not enabled in netifd. Signed-off-by: Alin Nastac <alin.nastac@technicolor.com>
Diffstat (limited to 'package/network/config/vti')
-rw-r--r--package/network/config/vti/Makefile2
-rwxr-xr-xpackage/network/config/vti/files/vti.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/config/vti/Makefile b/package/network/config/vti/Makefile
index ffac77ab91..292ab111e5 100644
--- a/package/network/config/vti/Makefile
+++ b/package/network/config/vti/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=vti
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/vti/files/vti.sh b/package/network/config/vti/files/vti.sh
index ebfd9d41e1..96b65e76d9 100755
--- a/package/network/config/vti/files/vti.sh
+++ b/package/network/config/vti/files/vti.sh
@@ -149,6 +149,6 @@ proto_vti6_init_config() {
}
[ -n "$INCLUDE_ONLY" ] || {
- [ -f /lib/modules/$(uname -r)/ip_vti.ko ] && add_protocol vti
- [ -f /lib/modules/$(uname -r)/ip6_vti.ko ] && add_protocol vti6
+ [ -d /sys/module/ip_vti ] && add_protocol vti
+ [ -d /sys/module/ip6_vti ] && add_protocol vti6
}