aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/gre/Makefile
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2014-07-30 13:22:24 +0000
committerSteven Barth <cyrus@openwrt.org>2014-07-30 13:22:24 +0000
commit7dabdbde78794c96513fb427675fb9517e2b135a (patch)
treeb9ec396ac31d1910652b09d4c7c46ff8c0fea5d7 /package/network/config/gre/Makefile
parente413bb0e7e3cffae84b203e94a2aa90df5d6c631 (diff)
downloadupstream-7dabdbde78794c96513fb427675fb9517e2b135a.tar.gz
upstream-7dabdbde78794c96513fb427675fb9517e2b135a.tar.bz2
upstream-7dabdbde78794c96513fb427675fb9517e2b135a.zip
gre: Generic Routing Encapsulation package support
The package supports Generic Routing Encapsulation support by registering following protocol kinds: -gre -gretap -grev6 -grev6tap Following options are valid for gre and gretap kinds: -ipaddr -peeraddr -df -mtu -ttl -tunlink -zone -ikey -okey -icsum -ocsum -iseqno -oseqno The gretap kind supports additionally the network option Following options are valid for grev6 and grev6tap kinds: -ip6addr -peer6addr -weakif -mtu -ttl -tunlink -zone -ikey -okey -icsum -ocsum -iseqno -oseqno The grev6tap kind supports additionally the network option Typical network config for a GREv4 tunnel : config interface 'gre' option peeraddr '172.16.18.240' option mtu '1400' option proto 'gre' option tunlink 'wan' option zone 'tunnel' Typical network config for a GREv4 tap tunnel : config interface 'gretap' option peeraddr '195.207.5.79' option mtu '1400' option proto 'gretap' option zone 'tunnel' option tunlink 'wan' option network 'wlan_ap' I added myself as maintainer for the moment; feel free to change. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> SVN-Revision: 41897
Diffstat (limited to 'package/network/config/gre/Makefile')
-rw-r--r--package/network/config/gre/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/package/network/config/gre/Makefile b/package/network/config/gre/Makefile
new file mode 100644
index 0000000000..efca4643d5
--- /dev/null
+++ b/package/network/config/gre/Makefile
@@ -0,0 +1,64 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gre
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/gre/Default
+ SECTION:=net
+ CATEGORY:=Network
+ MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
+endef
+
+define Package/gre
+$(call Package/gre/Default)
+ TITLE:=Generic Routing Encapsulation config support
+endef
+
+define Package/gre/description
+ Generic Routing Encapsulation config support (IPv4 and IPv6) in /etc/config/network.
+endef
+
+define Package/grev4
+$(call Package/gre/Default)
+ TITLE:=Generic Routing Encapsulation (IPv4) config support
+ DEPENDS:=@(PACKAGE_gre) +kmod-gre
+endef
+
+define Package/grev4/description
+ Generic Routing Encapsulation config support (IPv4) in /etc/config/network.
+endef
+
+define Package/grev6
+$(call Package/gre/Default)
+ TITLE:=Generic Routing Encapsulation (IPv6) config support
+ DEPENDS:=@(PACKAGE_gre) +kmod-ipv6 +kmod-ip6-gre
+endef
+
+define Package/grev6/description
+ Generic Routing Encapsulation config support (IPv6) in /etc/config/network.
+endef
+
+define Build/Compile
+endef
+
+define Build/Configure
+endef
+
+define Package/gre/install
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/gre.sh $(1)/lib/netifd/proto/gre.sh
+endef
+
+$(eval $(call BuildPackage,gre))
+$(eval $(call BuildPackage,grev4))
+$(eval $(call BuildPackage,grev6))