aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/firewall
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-10-23 10:25:26 +0000
committerSteven Barth <cyrus@openwrt.org>2013-10-23 10:25:26 +0000
commitbb699867e032c4a6e681f9bde4325b88914392c5 (patch)
tree58a06b9714aa22eba871cb98c76f9a09b8365479 /package/network/config/firewall
parenta54f104701bdcfc9e892377c66bdaa37a8e9b57d (diff)
downloadupstream-bb699867e032c4a6e681f9bde4325b88914392c5.tar.gz
upstream-bb699867e032c4a6e681f9bde4325b88914392c5.tar.bz2
upstream-bb699867e032c4a6e681f9bde4325b88914392c5.zip
firewall: Improve ubus support
* Use network.interface dump call instead of individual status calls to reduce overall netifd lookups and invokes to 1 per fw3 process. * Allow protocol handlers to assign a firewall zone for an interface in the data section to allow for dynamic firewall zone assignment. SVN-Revision: 38504
Diffstat (limited to 'package/network/config/firewall')
-rw-r--r--package/network/config/firewall/Makefile4
-rw-r--r--package/network/config/firewall/files/firewall.hotplug2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index 0d495117d4..ac4d16a388 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
-PKG_VERSION:=2013-10-10
+PKG_VERSION:=2013-10-23
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/firewall3.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=fca5e39564e488b169c8c535dcf658649f81429e
+PKG_SOURCE_VERSION:=c25922c05ae594c4c35fa65f27fd21c3a033f4ec
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
diff --git a/package/network/config/firewall/files/firewall.hotplug b/package/network/config/firewall/files/firewall.hotplug
index 34f3afec9b..20a95d4363 100644
--- a/package/network/config/firewall/files/firewall.hotplug
+++ b/package/network/config/firewall/files/firewall.hotplug
@@ -1,6 +1,6 @@
#!/bin/sh
-[ "$ACTION" = ifup ] || exit 0
+[ "$ACTION" = ifup -o "$ACTION" = ifupdate ] || exit 0
/etc/init.d/firewall enabled || exit 0