aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/firewall
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-09-19 12:03:26 -0700
committerJohn Crispin <john@phrozen.org>2018-10-11 08:05:41 +0200
commit49065d227a8ff2b4ceb758b501c5dfeba4dc1e67 (patch)
tree7a65a4f714df2db6a92899189d9411d363d07400 /package/network/config/firewall
parentba826ce4e7880d81f7c73821f2221e90493cb3f8 (diff)
downloadupstream-49065d227a8ff2b4ceb758b501c5dfeba4dc1e67.tar.gz
upstream-49065d227a8ff2b4ceb758b501c5dfeba4dc1e67.tar.bz2
upstream-49065d227a8ff2b4ceb758b501c5dfeba4dc1e67.zip
firewall: Install config files as 600
None of the files in firewall are used by non-root. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/network/config/firewall')
-rw-r--r--package/network/config/firewall/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index 830a1b268f..2c1224de38 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -9,10 +9,10 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL=$(PROJECT_GIT)/project/firewall3.git
+PKG_SOURCE_URL:=$(PROJECT_GIT)/project/firewall3.git
PKG_SOURCE_DATE:=2018-08-13
PKG_SOURCE_VERSION:=1c4d5bcd1137e61e91dca858fe33d76d7a1dc821
PKG_MIRROR_HASH:=49f939877a734056455556c90b959c407fd2c4988dc5d86f62a8122ebd7b8899
@@ -50,13 +50,13 @@ define Package/firewall/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
- $(INSTALL_DATA) ./files/firewall.hotplug $(1)/etc/hotplug.d/iface/20-firewall
+ $(INSTALL_CONF) ./files/firewall.hotplug $(1)/etc/hotplug.d/iface/20-firewall
$(INSTALL_DIR) $(1)/etc/config/
- $(INSTALL_DATA) ./files/firewall.config $(1)/etc/config/firewall
+ $(INSTALL_CONF) ./files/firewall.config $(1)/etc/config/firewall
$(INSTALL_DIR) $(1)/etc/
- $(INSTALL_DATA) ./files/firewall.user $(1)/etc/firewall.user
+ $(INSTALL_CONF) ./files/firewall.user $(1)/etc/firewall.user
$(INSTALL_DIR) $(1)/usr/share/fw3
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/helpers.conf $(1)/usr/share/fw3
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/helpers.conf $(1)/usr/share/fw3
endef
$(eval $(call BuildPackage,firewall))