aboutsummaryrefslogtreecommitdiffstats
path: root/package/ncurses
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-26 17:51:14 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-26 17:51:14 +0000
commitac94d4c3d15ecafcda6ead78188fb1620f6e1352 (patch)
treedbba18aafa3b2f4e65784b0fbdc2489306b7f96d /package/ncurses
parent0d69a941a23865302d0ed4f4d277e426c82c04bb (diff)
downloadupstream-ac94d4c3d15ecafcda6ead78188fb1620f6e1352.tar.gz
upstream-ac94d4c3d15ecafcda6ead78188fb1620f6e1352.tar.bz2
upstream-ac94d4c3d15ecafcda6ead78188fb1620f6e1352.zip
package/ncurses: fix freebsd install issues
SVN-Revision: 24149
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/ncurses/Makefile b/package/ncurses/Makefile
index 8fac06eca1..8043588508 100644
--- a/package/ncurses/Makefile
+++ b/package/ncurses/Makefile
@@ -51,11 +51,18 @@ CONFIGURE_ARGS += \
--without-debug \
--without-profile \
--without-progs \
+ --disable-big-core \
+ --disable-home-terminfo \
--with-normal \
--with-shared \
--with-terminfo-dirs=/usr/share/terminfo \
--with-default-terminfo-dir=/usr/share/terminfo
+ifeq ($(HOST_OS),FreeBSD)
+ CONFIGURE_ARGS +=
+ --with-terminfo=/usr/share/terminfo.db
+endif
+
ifeq ($(BUILD_VARIANT),libncursesw)
CONFIGURE_ARGS += \
--enable-widec \
@@ -78,6 +85,7 @@ endef
define Package/libncurses/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{curses,ncurses,panel,menu,form}.so* $(1)/usr/lib/
+ifneq ($(HOST_OS),FreeBSD)
$(INSTALL_DIR) $(1)/usr/share/terminfo
(cd $(PKG_INSTALL_DIR)/usr/share/terminfo; \
for dir in ??; do \
@@ -90,6 +98,7 @@ define Package/libncurses/install
$(CP) $(PKG_INSTALL_DIR)/usr/share/terminfo/$$$$file \
$(1)/usr/share/terminfo/$$$$file; \
done
+endif
endef
define Package/libncursesw/install