aboutsummaryrefslogtreecommitdiffstats
path: root/package/mtd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-01-19 21:28:22 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-01-19 21:28:22 +0000
commitc8e7192064680ec3c44c6161312e93be6e871c83 (patch)
tree32050fb7d3fbb95737b2d13c8eb2f2935019d564 /package/mtd
parent10f41663ff11079a9333c592a0ad494d595ecaeb (diff)
downloadupstream-c8e7192064680ec3c44c6161312e93be6e871c83.tar.gz
upstream-c8e7192064680ec3c44c6161312e93be6e871c83.tar.bz2
upstream-c8e7192064680ec3c44c6161312e93be6e871c83.zip
mtd: treat failure to open FIS partition as fatal when a fis_layout is given, aborts mtd write if reformat is needed and FIS table not available
SVN-Revision: 19231
Diffstat (limited to 'package/mtd')
-rw-r--r--package/mtd/Makefile2
-rw-r--r--package/mtd/src/fis.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/mtd/Makefile b/package/mtd/Makefile
index 172235d302..ced26d5c6c 100644
--- a/package/mtd/Makefile
+++ b/package/mtd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mtd
-PKG_RELEASE:=10
+PKG_RELEASE:=11
PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
STAMP_PREPARED := $(STAMP_PREPARED)_$(call confvar,CONFIG_MTD_REDBOOT_PARTS)
diff --git a/package/mtd/src/fis.c b/package/mtd/src/fis.c
index f99101988d..3108c5a9e6 100644
--- a/package/mtd/src/fis.c
+++ b/package/mtd/src/fis.c
@@ -99,7 +99,7 @@ fis_validate(struct fis_part *old, int n_old, struct fis_part *new, int n_new)
desc = fis_open();
if (!desc)
- return 0;
+ return -1;
for (i = 0; i < n_new - 1; i++) {
if (!new[i].size) {