aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-06-15 21:17:17 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-06-15 21:17:17 +0000
commite8974127fbda8f099cfb4e870965dac64693408a (patch)
tree559e0ede74482e909ed503c392f932da47216059 /package/madwifi
parentdfcd340721e76af49cef4291fd24db41c13da21b (diff)
downloadupstream-e8974127fbda8f099cfb4e870965dac64693408a.tar.gz
upstream-e8974127fbda8f099cfb4e870965dac64693408a.tar.bz2
upstream-e8974127fbda8f099cfb4e870965dac64693408a.zip
madwifi: Fix linux 3.0 detection
Allows madwifi to be built against linux 3.0. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> SVN-Revision: 27188
Diffstat (limited to 'package/madwifi')
-rw-r--r--package/madwifi/patches/476-3.0_detection_fix.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/madwifi/patches/476-3.0_detection_fix.patch b/package/madwifi/patches/476-3.0_detection_fix.patch
new file mode 100644
index 0000000000..2f8bfb4a55
--- /dev/null
+++ b/package/madwifi/patches/476-3.0_detection_fix.patch
@@ -0,0 +1,25 @@
+--- a/Makefile
++++ b/Makefile
+@@ -155,13 +155,15 @@ unload:
+ configcheck:
+ @echo -n "Checking kernel configuration... "
+
+- @# check version of kernel
+- @echo $(KERNELRELEASE) | grep -q -i '^[2-9]\.[4-9]\.' || { \
+- echo "FAILED"; \
+- echo "Only kernel versions 2.4.x and above are supported."; \
+- echo "You have $(KERNELRELEASE)."; \
+- exit 1; \
+- }
++ @# check kernel version
++ @case $(KERNELRELEASE) in \
++ 2.[456].*) ;; \
++ [3-9].*) ;; \
++ *) echo "FAILED"; \
++ echo "Only kernel versions 2.4.x and above are supported."; \
++ echo "You have $(KERNELRELEASE)."; \
++ exit 1 ;; \
++ esac
+
+ @# check kernel configuration
+ @if [ -z "$(CONFIG_SYSCTL)" ]; then \