aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-01 21:29:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-01 21:29:10 +0000
commit9ce792f4441675792b420420c2f117d7c19977be (patch)
tree017d24b5bc787ebcddc882a963cd369989a7ce49 /package/madwifi/patches
parentb3b04354d306f04e32be35dcfeef246b2af8dd45 (diff)
downloadupstream-9ce792f4441675792b420420c2f117d7c19977be.tar.gz
upstream-9ce792f4441675792b420420c2f117d7c19977be.tar.bz2
upstream-9ce792f4441675792b420420c2f117d7c19977be.zip
madwifi: remove the get_arch.mk build failure when the 'detected' arch doesn't match the build system's value
SVN-Revision: 17084
Diffstat (limited to 'package/madwifi/patches')
-rw-r--r--package/madwifi/patches/106-get_arch.patch7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/madwifi/patches/106-get_arch.patch b/package/madwifi/patches/106-get_arch.patch
index 4873271138..3140f36799 100644
--- a/package/madwifi/patches/106-get_arch.patch
+++ b/package/madwifi/patches/106-get_arch.patch
@@ -1,6 +1,6 @@
--- a/scripts/get_arch.mk
+++ b/scripts/get_arch.mk
-@@ -36,6 +36,13 @@ ifeq (,$(ARCH-y))
+@@ -36,11 +36,14 @@ ifeq (,$(ARCH-y))
$(Cannot determine ARCH)
endif
@@ -14,3 +14,8 @@
# Don't allow ARCH to be overridden by a different value.
ifeq (,$(ARCH))
ARCH = $(ARCH-y)
+-else
+-ifneq ($(ARCH),$(ARCH-y))
+-$(error ARCH mismatch: supplied "$(ARCH)", determined "$(ARCH-y)")
+-endif
+ endif