aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi/patches/102-multicall_binary.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-11-02 13:04:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-11-02 13:04:36 +0000
commit3fc3e5a2041daa62212ceaff18792eef83e3d721 (patch)
tree76178f877ae760aef51dd6c1c7c88366adbabf95 /package/madwifi/patches/102-multicall_binary.patch
parent2380bfcec72d22312e41ca3f2f004089120c398c (diff)
downloadupstream-3fc3e5a2041daa62212ceaff18792eef83e3d721.tar.gz
upstream-3fc3e5a2041daa62212ceaff18792eef83e3d721.tar.bz2
upstream-3fc3e5a2041daa62212ceaff18792eef83e3d721.zip
madwifi: fix noderef and state machine issues in the currently unused ap-to-ap wds mode; refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13096 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/madwifi/patches/102-multicall_binary.patch')
-rw-r--r--package/madwifi/patches/102-multicall_binary.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/package/madwifi/patches/102-multicall_binary.patch b/package/madwifi/patches/102-multicall_binary.patch
index d3533ec68a..887a462e9f 100644
--- a/package/madwifi/patches/102-multicall_binary.patch
+++ b/package/madwifi/patches/102-multicall_binary.patch
@@ -8,7 +8,7 @@
#undef ARRAY_SIZE
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
-@@ -185,7 +186,7 @@
+@@ -185,7 +186,7 @@ sysctlbyname(const char *oid0, void *old
#endif /* __linux__ */
int
@@ -27,7 +27,7 @@
#ifndef SIOCG80211STATS
#define SIOCG80211STATS (SIOCDEVPRIVATE + 2)
-@@ -240,7 +241,7 @@
+@@ -240,7 +241,7 @@ print_sta_stats(FILE *fd, const u_int8_t
}
int
@@ -46,7 +46,7 @@
static int s = -1;
static const char *progname;
-@@ -140,8 +141,9 @@
+@@ -140,8 +141,9 @@ usage(void)
}
#define MAXCHAN ((int)(sizeof(struct ieee80211req_chanlist) * NBBY))
@@ -67,7 +67,7 @@
static int
setsysctrl(const char *dev, const char *control , u_long value)
-@@ -88,7 +89,7 @@
+@@ -88,7 +89,7 @@ static void usage(void)
}
int
@@ -86,7 +86,7 @@
#undef ARRAY_SIZE
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
-@@ -194,7 +195,7 @@
+@@ -194,7 +195,7 @@ sysctlbyname(const char *oid0, void *old
#endif /* __linux__ */
int
@@ -105,7 +105,7 @@
static int s = -1;
static const char *progname;
-@@ -213,8 +214,7 @@
+@@ -213,8 +214,7 @@ usage(void)
exit(-1);
}
@@ -125,7 +125,7 @@
static const struct {
u_int phyerr;
-@@ -228,7 +229,7 @@
+@@ -228,7 +229,7 @@ catchalarm(int signo)
}
int
@@ -190,7 +190,7 @@
+#endif
--- a/tools/Makefile
+++ b/tools/Makefile
-@@ -46,56 +46,55 @@
+@@ -46,56 +46,55 @@ ifeq ($(HAL),)
HAL= $(TOP)/hal
endif
@@ -284,7 +284,7 @@
/*
* These are taken from ieee80211_node.h
-@@ -100,7 +101,7 @@
+@@ -100,7 +101,7 @@ size_t strlcat(char *, const char *, siz
static int verbose = 0;
int
@@ -303,7 +303,7 @@
#undef ARRAY_SIZE
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
-@@ -738,7 +739,8 @@
+@@ -738,7 +739,8 @@ static void usage(const char *n)
"unlawful radio transmissions!\n\n");
}