aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-22 08:02:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-22 08:02:59 +0000
commit88e7da2babd4cc61032f2047525cfd1c56d09068 (patch)
tree51b4c36449ec4a005ffec713c74f90ec4f6d9ac7 /package/madwifi/Makefile
parenta5546e6c40074a4c95b7bcf192a68e95e87ad306 (diff)
downloadupstream-88e7da2babd4cc61032f2047525cfd1c56d09068.tar.gz
upstream-88e7da2babd4cc61032f2047525cfd1c56d09068.tar.bz2
upstream-88e7da2babd4cc61032f2047525cfd1c56d09068.zip
nuke old madwifi init script, add new /lib/wifi handler (usable for many configurations already), fix up a target name
SVN-Revision: 5889
Diffstat (limited to 'package/madwifi/Makefile')
-rw-r--r--package/madwifi/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index b0e5be8712..f59daddc1d 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -41,7 +41,7 @@ ifeq ($(ARCH),powerpc)
endif
BUS:=PCI
-ifneq ($(CONFIG_LINUX_2_6_AR531X),)
+ifneq ($(CONFIG_LINUX_2_6_ATHEROS),)
BUS:=AHB
HAL_TARGET:=ap51
endif
@@ -140,8 +140,8 @@ define Build/UninstallDev
endef
define KernelPackage/madwifi/install
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/madwifi.init $(1)/etc/init.d/madwifi
+ $(INSTALL_DIR) $(1)/lib/wifi
+ $(INSTALL_DATA) ./files/lib/wifi/madwifi.sh $(1)/lib/wifi
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_BUILD_DIR)/tools/{madwifi_multi,80211debug,80211stats,athchans,athctrl,athdebug,athkey,athstats,wlanconfig} $(1)/usr/sbin/
endef