aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/401-ath9k-dont-register-leds-on-ar9100.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-20 14:59:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-20 14:59:55 +0000
commit9b11d6fa983420e19211810f96ca3d1e30404f35 (patch)
tree2e9a5e4cfa2c88a33fd9bf6e79c39089251629e0 /package/mac80211/patches/401-ath9k-dont-register-leds-on-ar9100.patch
parent59d130d86713c0c81543ff73e7fade9212ede98f (diff)
downloadupstream-9b11d6fa983420e19211810f96ca3d1e30404f35.tar.gz
upstream-9b11d6fa983420e19211810f96ca3d1e30404f35.tar.bz2
upstream-9b11d6fa983420e19211810f96ca3d1e30404f35.zip
upgrade mac80211 to 2008-08-20 and clean up some unnecessary patching to config.mk, which frequently causes rejects on new versions
SVN-Revision: 17326
Diffstat (limited to 'package/mac80211/patches/401-ath9k-dont-register-leds-on-ar9100.patch')
-rw-r--r--package/mac80211/patches/401-ath9k-dont-register-leds-on-ar9100.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/mac80211/patches/401-ath9k-dont-register-leds-on-ar9100.patch b/package/mac80211/patches/401-ath9k-dont-register-leds-on-ar9100.patch
index afaabb12c6..71b0ae469e 100644
--- a/package/mac80211/patches/401-ath9k-dont-register-leds-on-ar9100.patch
+++ b/package/mac80211/patches/401-ath9k-dont-register-leds-on-ar9100.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/ath9k/main.c
+++ b/drivers/net/wireless/ath/ath9k/main.c
-@@ -1057,6 +1057,9 @@ static void ath_unregister_led(struct at
+@@ -1054,6 +1054,9 @@ static void ath_unregister_led(struct at
static void ath_deinit_leds(struct ath_softc *sc)
{
@@ -10,13 +10,13 @@
ath_unregister_led(&sc->assoc_led);
sc->sc_flags &= ~SC_OP_LED_ASSOCIATED;
ath_unregister_led(&sc->tx_led);
-@@ -1070,6 +1073,9 @@ static void ath_init_leds(struct ath_sof
- char *trigger;
- int ret;
+@@ -1072,6 +1075,9 @@ static void ath_init_leds(struct ath_sof
+ else
+ sc->sc_ah->led_pin = ATH_LED_PIN_DEF;
+ if (AR_SREV_9100(sc->sc_ah))
+ return;
+
/* Configure gpio 1 for output */
- ath9k_hw_cfg_output(sc->sc_ah, ATH_LED_PIN,
+ ath9k_hw_cfg_output(sc->sc_ah, sc->sc_ah->led_pin,
AR_GPIO_OUTPUT_MUX_AS_OUTPUT);