aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-08-06 20:18:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-08-06 20:18:07 +0000
commit74c27a1a9281c6fdc9a3987c8a8629654f0f2914 (patch)
tree5102328e6824dc21f5fe3eab0bfbad0874463cd1 /package/mac80211/Makefile
parent54f30d4f460d9d9ae73a60d2c51cd3932310c720 (diff)
downloadupstream-74c27a1a9281c6fdc9a3987c8a8629654f0f2914.tar.gz
upstream-74c27a1a9281c6fdc9a3987c8a8629654f0f2914.tar.bz2
upstream-74c27a1a9281c6fdc9a3987c8a8629654f0f2914.zip
mac80211: do not delete linux/*_platform.h, they are touched by patches. instead make the build fail if they differ from the ones in the kernel tree to prevent subtle runtime issues (see #11981)
SVN-Revision: 33030
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index f1a797e607..986fd93a8c 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -1331,9 +1331,6 @@ define Build/Prepare
rm -rf $(PKG_BUILD_DIR)/include/linux/bcma
rm -rf $(PKG_BUILD_DIR)/include/net/bluetooth/
rm -f $(PKG_BUILD_DIR)/include/linux/eeprom_93cx6.h
- rm -f $(PKG_BUILD_DIR)/include/linux/ath9k_platform.h
- rm -f $(PKG_BUILD_DIR)/include/linux/ath5k_platform.h
- rm -f $(PKG_BUILD_DIR)/include/linux/rt2x00_platform.h
rm -f $(PKG_BUILD_DIR)/include/linux/wl12xx.h
rm -f $(PKG_BUILD_DIR)/include/linux/spi/libertas_spi.h
rm -f $(PKG_BUILD_DIR)/include/net/ieee80211.h
@@ -1348,6 +1345,12 @@ ifneq ($(CONFIG_PACKAGE_kmod-cfg80211)$(CONFIG_PACKAGE_kmod-lib80211),)
endef
endif
+define Build/Configure
+ cmp $(PKG_BUILD_DIR)/include/linux/ath9k_platform.h $(LINUX_DIR)/include/linux/ath9k_platform.h
+ cmp $(PKG_BUILD_DIR)/include/linux/ath5k_platform.h $(LINUX_DIR)/include/linux/ath5k_platform.h
+ cmp $(PKG_BUILD_DIR)/include/linux/rt2x00_platform.h $(LINUX_DIR)/include/linux/rt2x00_platform.h
+endef
+
define Build/Compile
$(call Build/Compile/kmod)
endef