aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-tapi
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-03-29 05:17:10 +0000
committerJohn Crispin <john@openwrt.org>2011-03-29 05:17:10 +0000
commitdb56769b0a1c5b9bcc4506850de78ceeeb7f4334 (patch)
treef369371c34c3899fbb890b060adb71b43b645349 /package/ltq-tapi
parent1dbabd309b922bb5782755f11615317068915da3 (diff)
downloadupstream-db56769b0a1c5b9bcc4506850de78ceeeb7f4334.tar.gz
upstream-db56769b0a1c5b9bcc4506850de78ceeeb7f4334.tar.bz2
upstream-db56769b0a1c5b9bcc4506850de78ceeeb7f4334.zip
* several updates to the voice packages
SVN-Revision: 26351
Diffstat (limited to 'package/ltq-tapi')
-rw-r--r--package/ltq-tapi/Makefile2
-rw-r--r--package/ltq-tapi/patches/000-portability.patch (renamed from package/ltq-tapi/patches/001-portability.patch)32
-rw-r--r--package/ltq-tapi/patches/100-ifxmips.patch8
-rw-r--r--package/ltq-tapi/patches/200-linux-37.patch (renamed from package/ltq-tapi/patches/linux-37.patch)12
4 files changed, 21 insertions, 33 deletions
diff --git a/package/ltq-tapi/Makefile b/package/ltq-tapi/Makefile
index 6c530ac877..ecaac2eeb4 100644
--- a/package/ltq-tapi/Makefile
+++ b/package/ltq-tapi/Makefile
@@ -22,7 +22,7 @@ define KernelPackage/ltq-tapi
SUBMENU:=Voice over IP
TITLE:=Lantiq TAPI subsystem
URL:=http://www.lantiq.com/
- DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq_xway
+ DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq
FILES:=$(PKG_BUILD_DIR)/src/drv_tapi.ko
AUTOLOAD:=$(call AutoLoad,20,drv_tapi)
MAINTAINER:=John Crispin <blogic@openwrt.org>
diff --git a/package/ltq-tapi/patches/001-portability.patch b/package/ltq-tapi/patches/000-portability.patch
index 3e6b9cf82e..78fcbad668 100644
--- a/package/ltq-tapi/patches/001-portability.patch
+++ b/package/ltq-tapi/patches/000-portability.patch
@@ -1,6 +1,6 @@
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -149,7 +149,7 @@ if KERNEL_2_6
+@@ -154,7 +154,7 @@ if KERNEL_2_6
drv_tapi_OBJS = "$(subst .c,.o, $(drv_tapi_SOURCES))"
drv_tapi.ko: $(drv_tapi_SOURCES) $(EXTRA_DIST)
@@ -9,7 +9,7 @@
@for f in $(drv_tapi_SOURCES) ; do \
if test ! -e $(PWD)/$$f; then \
echo " LN $$f" ; \
-@@ -157,10 +157,10 @@ drv_tapi.ko: $(drv_tapi_SOURCES) $(EXTRA
+@@ -162,10 +162,10 @@ drv_tapi.ko: $(drv_tapi_SOURCES) $(EXTRA
ln -s @abs_srcdir@/$$f $(PWD)/$$f; \
fi; \
done;
@@ -47,17 +47,6 @@
#include "ifx_types.h" /* ifx type definitions */
--- a/src/drv_tapi_linux.c
+++ b/src/drv_tapi_linux.c
-@@ -55,7 +55,7 @@
- #include <linux/sched.h>
- #undef CONFIG_DEVFS_FS
- #ifndef UTS_RELEASE
-- #include "linux/utsrelease.h"
-+ #include <utsrelease.h>
- #endif /* UTC_RELEASE */
- #else
- #include <linux/tqueue.h>
---- a/src/drv_tapi_linux.c
-+++ b/src/drv_tapi_linux.c
@@ -47,6 +47,7 @@
#include <linux/errno.h>
#include <asm/uaccess.h> /* copy_from_user(), ... */
@@ -66,21 +55,20 @@
#include <asm/io.h>
#ifdef LINUX_2_6
-@@ -55,12 +56,11 @@
+@@ -55,7 +56,11 @@
#include <linux/sched.h>
#undef CONFIG_DEVFS_FS
#ifndef UTS_RELEASE
-- #include <utsrelease.h>
-+ #include <generated/utsrelease.h>
+- #include "linux/utsrelease.h"
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33))
++# include <linux/utsrelease.h>
++#else
++# include <generated/utsrelease.h>
++#endif
#endif /* UTC_RELEASE */
#else
#include <linux/tqueue.h>
- #include <linux/sched.h>
-- #include <linux/smp_lock.h> /* lock_kernel() */
- #endif /* LINUX_2_6 */
-
- #include "drv_tapi.h"
-@@ -3600,7 +3600,11 @@ IFX_void_t TAPI_OS_ThreadKill(IFXOS_Thre
+@@ -3718,7 +3723,11 @@ IFX_void_t TAPI_OS_ThreadKill(IFXOS_Thre
flag and released after the down() call. */
lock_kernel();
mb();
diff --git a/package/ltq-tapi/patches/100-ifxmips.patch b/package/ltq-tapi/patches/100-ifxmips.patch
index 13c59f622f..a9c0d8116b 100644
--- a/package/ltq-tapi/patches/100-ifxmips.patch
+++ b/package/ltq-tapi/patches/100-ifxmips.patch
@@ -1,6 +1,6 @@
--- a/src/drv_tapi_linux.c
+++ b/src/drv_tapi_linux.c
-@@ -544,7 +544,7 @@ static ssize_t ifx_tapi_write (struct fi
+@@ -552,7 +552,7 @@ static ssize_t ifx_tapi_write (struct fi
IFX_uint8_t *pData;
IFX_size_t buf_size;
#endif /* TAPI_PACKET */
@@ -69,9 +69,9 @@
/* ============================= */
--- a/src/lib/lib_bufferpool/lib_bufferpool.c
+++ b/src/lib/lib_bufferpool/lib_bufferpool.c
-@@ -80,24 +80,6 @@
- #include <linux/slab.h>
- #endif /* LINUX */
+@@ -85,24 +85,6 @@
+ #include <stdlib.h>
+ #endif /*VXWORKS*/
-
-/* ============================= */
diff --git a/package/ltq-tapi/patches/linux-37.patch b/package/ltq-tapi/patches/200-linux-37.patch
index 5d5ff7ed3e..0eac62ff9a 100644
--- a/package/ltq-tapi/patches/linux-37.patch
+++ b/package/ltq-tapi/patches/200-linux-37.patch
@@ -1,6 +1,6 @@
--- a/src/drv_tapi_linux.c
+++ b/src/drv_tapi_linux.c
-@@ -128,8 +128,13 @@
+@@ -146,8 +146,13 @@ static ssize_t ifx_tapi_write(struct fil
size_t count, loff_t * ppos);
static ssize_t ifx_tapi_read(struct file * filp, char *buf,
size_t length, loff_t * ppos);
@@ -8,13 +8,13 @@
static int ifx_tapi_ioctl(struct inode *inode, struct file *filp,
unsigned int nCmd, unsigned long nArgument);
+#else
-+static int ifx_tapi_ioctl(struct file *filp,
++static long ifx_tapi_ioctl(struct file *filp,
+ unsigned int nCmd, unsigned long nArgument);
+#endif
static unsigned int ifx_tapi_poll (struct file *filp, poll_table *table);
#ifdef CONFIG_PROC_FS
-@@ -213,7 +218,11 @@
+@@ -231,7 +236,11 @@ IFX_return_t TAPI_OS_RegisterLLDrv (IFX_
IFX_char_t *pRegDrvName = IFX_NULL;
IFX_int32_t ret = 0;
@@ -26,7 +26,7 @@
{
#ifdef MODULE
tapi_fops.owner = THIS_MODULE;
-@@ -221,7 +230,11 @@
+@@ -239,7 +248,11 @@ IFX_return_t TAPI_OS_RegisterLLDrv (IFX_
tapi_fops.read = ifx_tapi_read;
tapi_fops.write = ifx_tapi_write;
tapi_fops.poll = ifx_tapi_poll;
@@ -38,7 +38,7 @@
tapi_fops.open = ifx_tapi_open;
tapi_fops.release = ifx_tapi_release;
}
-@@ -876,8 +889,13 @@
+@@ -894,8 +907,13 @@ static IFX_uint32_t ifx_tapi_poll (struc
- 0 and positive values - success
- negative value - ioctl failed
*/
@@ -46,7 +46,7 @@
static int ifx_tapi_ioctl(struct inode *inode, struct file *filp,
unsigned int nCmd, unsigned long nArg)
+#else
-+static int ifx_tapi_ioctl(struct file *filp,
++static long ifx_tapi_ioctl(struct file *filp,
+ unsigned int nCmd, unsigned long nArg)
+#endif
{