aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-tapi
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-03-11 08:21:21 +0000
committerJohn Crispin <blogic@openwrt.org>2011-03-11 08:21:21 +0000
commit4c6f9be7329a182fdee1d7a75214cd264b94610a (patch)
treed6ecd75779514fa415443ec2769dc4a146d4eacb /package/ltq-tapi
parentdd9774097f4925ad6ec5adce83b35ec3fe53648c (diff)
downloadupstream-4c6f9be7329a182fdee1d7a75214cd264b94610a.tar.gz
upstream-4c6f9be7329a182fdee1d7a75214cd264b94610a.tar.bz2
upstream-4c6f9be7329a182fdee1d7a75214cd264b94610a.zip
[lantiq]
* fixes dsl, ifxos, tapi and vmcc for .37 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26023 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ltq-tapi')
-rw-r--r--package/ltq-tapi/Makefile2
-rw-r--r--package/ltq-tapi/patches/linux-37.patch31
2 files changed, 32 insertions, 1 deletions
diff --git a/package/ltq-tapi/Makefile b/package/ltq-tapi/Makefile
index ecaac2eeb4..6c530ac877 100644
--- a/package/ltq-tapi/Makefile
+++ b/package/ltq-tapi/Makefile
@@ -22,7 +22,7 @@ define KernelPackage/ltq-tapi
SUBMENU:=Voice over IP
TITLE:=Lantiq TAPI subsystem
URL:=http://www.lantiq.com/
- DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq
+ DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq_xway
FILES:=$(PKG_BUILD_DIR)/src/drv_tapi.ko
AUTOLOAD:=$(call AutoLoad,20,drv_tapi)
MAINTAINER:=John Crispin <blogic@openwrt.org>
diff --git a/package/ltq-tapi/patches/linux-37.patch b/package/ltq-tapi/patches/linux-37.patch
new file mode 100644
index 0000000000..6266ca14a8
--- /dev/null
+++ b/package/ltq-tapi/patches/linux-37.patch
@@ -0,0 +1,31 @@
+--- a/src/drv_tapi_linux.c
++++ b/src/drv_tapi_linux.c
+@@ -213,7 +213,7 @@
+ IFX_char_t *pRegDrvName = IFX_NULL;
+ IFX_int32_t ret = 0;
+
+- if (tapi_fops.ioctl == IFX_NULL)
++ if (tapi_fops.unlocked_ioctl == IFX_NULL)
+ {
+ #ifdef MODULE
+ tapi_fops.owner = THIS_MODULE;
+@@ -221,7 +221,7 @@
+ tapi_fops.read = ifx_tapi_read;
+ tapi_fops.write = ifx_tapi_write;
+ tapi_fops.poll = ifx_tapi_poll;
+- tapi_fops.ioctl = ifx_tapi_ioctl;
++ tapi_fops.unlocked_ioctl = ifx_tapi_ioctl;
+ tapi_fops.open = ifx_tapi_open;
+ tapi_fops.release = ifx_tapi_release;
+ }
+--- a/src/lib/lib_fifo/lib_fifo.c
++++ b/src/lib/lib_fifo/lib_fifo.c
+@@ -41,7 +41,7 @@
+ #ifdef LINUX
+ /* if linux/slab.h is not available, use the precessor linux/malloc.h */
+ #include <linux/slab.h>
+-#elif VXWORKS
++#elif defined(VXWORKS)
+ #include <sys_drv_debug.h>
+ #endif /* LINUX */
+