aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-ifxos/patches
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-02-01 14:32:25 +0000
committerJohn Crispin <john@openwrt.org>2011-02-01 14:32:25 +0000
commitfd551c1fa7526aca631a07f0fd3134433c9fa5fe (patch)
tree1b6db352842d684f7cbd478a2dbc1724d09cdfe5 /package/ltq-ifxos/patches
parent79b3d8f69aa02e2dc80f04a1ac84e971a2a33f8b (diff)
downloadupstream-fd551c1fa7526aca631a07f0fd3134433c9fa5fe.tar.gz
upstream-fd551c1fa7526aca631a07f0fd3134433c9fa5fe.tar.bz2
upstream-fd551c1fa7526aca631a07f0fd3134433c9fa5fe.zip
* rename voice package * sync with lantiqs release * make it work on lantiq kernel
SVN-Revision: 25275
Diffstat (limited to 'package/ltq-ifxos/patches')
-rw-r--r--package/ltq-ifxos/patches/100-portability.patch37
-rw-r--r--package/ltq-ifxos/patches/110-fix-2.6.32-wakeup.patch12
2 files changed, 49 insertions, 0 deletions
diff --git a/package/ltq-ifxos/patches/100-portability.patch b/package/ltq-ifxos/patches/100-portability.patch
new file mode 100644
index 0000000000..1316888d65
--- /dev/null
+++ b/package/ltq-ifxos/patches/100-portability.patch
@@ -0,0 +1,37 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -639,7 +639,7 @@ if KERNEL_2_6
+ drv_ifxos_OBJS = "$(subst .c,.o,$(filter %.c,$(drv_ifxos_SOURCES)))"
+
+ drv_ifxos.ko: $(drv_ifxos_SOURCES)
+- @echo -e "drv_ifxos: Making Linux 2.6.x kernel object"
++ @echo "drv_ifxos: Making Linux 2.6.x kernel object"
+ if test ! -e common/ifxos_debug.c ; then \
+ echo "copy source files (as links only!)"; \
+ for f in $(filter %.c,$(drv_ifxos_SOURCES)); do \
+@@ -647,10 +647,10 @@ drv_ifxos.ko: $(drv_ifxos_SOURCES)
+ cp -s $(addprefix @abs_srcdir@/,$$f) $(PWD)/`dirname $$f`/ ; \
+ done \
+ fi
+- @echo -e "# drv_ifxos: Generated to build Linux 2.6.x kernel object" > $(PWD)/Kbuild
+- @echo -e "obj-m := $(subst .ko,.o,$@)" >> $(PWD)/Kbuild
+- @echo -e "$(subst .ko,,$@)-y := $(drv_ifxos_OBJS)" >> $(PWD)/Kbuild
+- @echo -e "EXTRA_CFLAGS := $(CFLAGS) -DHAVE_CONFIG_H $(drv_ifxos_CFLAGS) $(DSL_DRIVER_INCL_PATH) -I@abs_srcdir@/include -I$(PWD)/include" >> $(PWD)/Kbuild
++ @echo "# drv_ifxos: Generated to build Linux 2.6.x kernel object" > $(PWD)/Kbuild
++ @echo "obj-m := $(subst .ko,.o,$@)" >> $(PWD)/Kbuild
++ @echo "$(subst .ko,,$@)-y := $(drv_ifxos_OBJS)" >> $(PWD)/Kbuild
++ @echo "EXTRA_CFLAGS := $(CFLAGS) -DHAVE_CONFIG_H $(drv_ifxos_CFLAGS) $(DSL_DRIVER_INCL_PATH) -I@abs_srcdir@/include -I$(PWD)/include" >> $(PWD)/Kbuild
+ $(MAKE) ARCH=@KERNEL_ARCH@ -C @KERNEL_BUILD_PATH@ O=@KERNEL_BUILD_PATH@ M=$(PWD) modules
+
+ clean-generic:
+--- a/configure.in
++++ b/configure.in
+@@ -64,7 +64,7 @@ dnl Set kernel build path
+ AC_ARG_ENABLE(kernelbuild,
+ AS_HELP_STRING(--enable-kernelbuild=x,Set the target kernel build path (only for kernel 2.6.x)),
+ [
+- if test -e $enableval/include/linux/autoconf.h; then
++ if test -e $enableval/include/linux/autoconf.h -o -e $enableval/include/generated/autoconf.h; then
+ AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
+ else
+ AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
diff --git a/package/ltq-ifxos/patches/110-fix-2.6.32-wakeup.patch b/package/ltq-ifxos/patches/110-fix-2.6.32-wakeup.patch
new file mode 100644
index 0000000000..da0bbd3234
--- /dev/null
+++ b/package/ltq-ifxos/patches/110-fix-2.6.32-wakeup.patch
@@ -0,0 +1,12 @@
+Index: lib_ifxos-1.5.12/src/linux/ifxos_linux_select_drv.c
+===================================================================
+--- lib_ifxos-1.5.12.orig/src/linux/ifxos_linux_select_drv.c 2010-04-24 11:33:55.000000000 +0200
++++ lib_ifxos-1.5.12/src/linux/ifxos_linux_select_drv.c 2010-04-24 11:34:21.000000000 +0200
+@@ -33,6 +33,7 @@
+ #include <linux/fs.h>
+ #include <linux/wait.h>
+ #include <linux/poll.h>
++#include <linux/sched.h>
+
+ #include "ifx_types.h"
+ #include "ifxos_rt_if_check.h"