aboutsummaryrefslogtreecommitdiffstats
path: root/package/linux-atm
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-04-12 12:59:09 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-04-12 12:59:09 +0000
commitb54bf538332f4cfbff9b61267a42cc963342e987 (patch)
treed44629a14bc205156728fac769fbf703deed5e63 /package/linux-atm
parent06cece53ef2c9b6a20190c1ec76a7de5f8f208ee (diff)
downloadupstream-b54bf538332f4cfbff9b61267a42cc963342e987.tar.gz
upstream-b54bf538332f4cfbff9b61267a42cc963342e987.tar.bz2
upstream-b54bf538332f4cfbff9b61267a42cc963342e987.zip
fix linux-atm build failure on brcm63xx (and probably other targets) (#7145)
SVN-Revision: 20826
Diffstat (limited to 'package/linux-atm')
-rw-r--r--package/linux-atm/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index c8a18c3d31..fd92cc1fff 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -47,13 +47,13 @@ define Build/Configure
touch $(PKG_BUILD_DIR)/stamp-h.in
endef
-TARGET_CFLAGS += -I$(LINUX_DIR)/include
+TARGET_CFLAGS += -I$(LINUX_DIR)/include -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include
define Build/Compile
# src/qgen is built with HOSTCC, which does not really like our LDFLAGS
$(MAKE) -C $(PKG_BUILD_DIR)/src/qgen \
LDFLAGS="" \
- all
+ all
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install