aboutsummaryrefslogtreecommitdiffstats
path: root/package/linux-atm
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-28 21:41:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-28 21:41:56 +0000
commit8da4498a2795894a0a32bb4a89e27e1fd112bee9 (patch)
treeca5b4eab172559169b9cb2415c544a2d548f8813 /package/linux-atm
parent1c036e4c7e828f8d1e0024021837c3d5064172c1 (diff)
downloadupstream-8da4498a2795894a0a32bb4a89e27e1fd112bee9.tar.gz
upstream-8da4498a2795894a0a32bb4a89e27e1fd112bee9.tar.bz2
upstream-8da4498a2795894a0a32bb4a89e27e1fd112bee9.zip
linux-atm: add the kernel include dir to the cflags and move the build dir to $(KERNEL_BUILD_DIR) to ensure that target specific ATM API changes are included
SVN-Revision: 20556
Diffstat (limited to 'package/linux-atm')
-rw-r--r--package/linux-atm/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index 07484c675f..c8a18c3d31 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -6,6 +6,7 @@
#
include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=linux-atm
PKG_VERSION:=2.5.1
@@ -46,6 +47,8 @@ define Build/Configure
touch $(PKG_BUILD_DIR)/stamp-h.in
endef
+TARGET_CFLAGS += -I$(LINUX_DIR)/include
+
define Build/Compile
# src/qgen is built with HOSTCC, which does not really like our LDFLAGS
$(MAKE) -C $(PKG_BUILD_DIR)/src/qgen \