aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-08 17:56:59 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2020-12-16 22:11:19 +0100
commite030a19a57af3729929eb718824dd57cb02c6876 (patch)
treed469f703f1b957993ce544eac565b79372f279f4 /package/libs
parent6cdc21b20e1125ece20eb871ff16d296a5e66688 (diff)
downloadupstream-e030a19a57af3729929eb718824dd57cb02c6876.tar.gz
upstream-e030a19a57af3729929eb718824dd57cb02c6876.tar.bz2
upstream-e030a19a57af3729929eb718824dd57cb02c6876.zip
libunwind: update to 1.5.0
Cleanup Makefile for consistency with other ones. Remove PKG_SSP. It can be fixed with -lssp_nonshared. Add PKG_BUILD_PARALLEL for faster compilation. Add zlib dependency. 1.5.0 requires it now. Refresh patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libunwind/Makefile17
-rw-r--r--package/libs/libunwind/patches/002-fix-building-getcontext_S.patch6
-rw-r--r--package/libs/libunwind/patches/003-fix-missing-ef_reg-defs-with-musl.patch8
3 files changed, 14 insertions, 17 deletions
diff --git a/package/libs/libunwind/Makefile b/package/libs/libunwind/Makefile
index 994ee97a17..89e6f84ff5 100644
--- a/package/libs/libunwind/Makefile
+++ b/package/libs/libunwind/Makefile
@@ -9,22 +9,22 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libunwind
-PKG_VERSION:=1.3.1
+PKG_VERSION:=1.5.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
-PKG_HASH:=43997a3939b6ccdf2f669b50fdb8a4d3205374728c2923ddc2354c65260214f8
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
+PKG_HASH:=90337653d92d4a13de590781371c604f9031cdb50520366aa1e3a91e1efb1017
+PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
PKG_LICENSE:=X11
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:libunwind_project:libunwind
-PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
-PKG_SSP:=0
include $(INCLUDE_DIR)/package.mk
define Package/libunwind
@@ -32,7 +32,7 @@ define Package/libunwind
CATEGORY:=Libraries
TITLE:=The libunwind project
URL:=http://www.nongnu.org/libunwind/
- DEPENDS:=@((mips||mipsel||x86_64||arm||aarch64)||(USE_GLIBC&&(powerpc||i386)))
+ DEPENDS:=@((mips||mipsel||x86_64||arm||aarch64)||(USE_GLIBC&&(powerpc||i386))) +zlib
ABI_VERSION:=8
endef
@@ -43,8 +43,9 @@ endef
CONFIGURE_ARGS += \
--disable-documentation \
--disable-tests \
- --enable-minidebuginfo=no \
+ --disable-minidebuginfo
+TARGET_LDFLAGS += $(if $(CONFIG_USE_MUSL),-lssp_nonshared)
define Package/libunwind/install
$(INSTALL_DIR) $(1)/usr/lib
diff --git a/package/libs/libunwind/patches/002-fix-building-getcontext_S.patch b/package/libs/libunwind/patches/002-fix-building-getcontext_S.patch
index 10b1dd1d90..d88594e6e7 100644
--- a/package/libs/libunwind/patches/002-fix-building-getcontext_S.patch
+++ b/package/libs/libunwind/patches/002-fix-building-getcontext_S.patch
@@ -1,6 +1,5 @@
-diff -uprN a/src/mips/getcontext.S b/src/mips/getcontext.S
---- a/src/mips/getcontext.S 2012-10-06 12:54:38.000000000 +0800
-+++ b/src/mips/getcontext.S 2016-06-08 13:35:25.033051679 +0800
+--- a/src/mips/getcontext.S
++++ b/src/mips/getcontext.S
@@ -24,12 +24,12 @@ OF CONTRACT, TORT OR OTHERWISE, ARISING
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. */
@@ -16,4 +15,3 @@ diff -uprN a/src/mips/getcontext.S b/src/mips/getcontext.S
# define OFFSET 4
# else
# define OFFSET 0
-
diff --git a/package/libs/libunwind/patches/003-fix-missing-ef_reg-defs-with-musl.patch b/package/libs/libunwind/patches/003-fix-missing-ef_reg-defs-with-musl.patch
index 465abb4ce0..1a26dcd895 100644
--- a/package/libs/libunwind/patches/003-fix-missing-ef_reg-defs-with-musl.patch
+++ b/package/libs/libunwind/patches/003-fix-missing-ef_reg-defs-with-musl.patch
@@ -1,7 +1,6 @@
-diff -uprN a/include/libunwind-mips.h b/include/libunwind-mips.h
---- a/include/libunwind-mips.h 2012-10-06 12:54:38.000000000 +0800
-+++ b/include/libunwind-mips.h 2016-06-08 13:55:55.029436442 +0800
-@@ -111,6 +111,42 @@ typedef enum
+--- a/include/libunwind-mips.h
++++ b/include/libunwind-mips.h
+@@ -114,6 +114,42 @@ typedef enum
}
mips_regnum_t;
@@ -44,4 +43,3 @@ diff -uprN a/include/libunwind-mips.h b/include/libunwind-mips.h
typedef enum
{
UNW_MIPS_ABI_O32,
-