aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-13 22:12:52 -0700
committerPetr Štetiar <ynezz@true.cz>2020-07-17 11:00:33 +0200
commitcc665802932f831e790f4f849214a56955458d34 (patch)
tree7d88e81fd9925505688f641b92aeea9b04e1ca53 /package/libs
parent480003e9eb0dac5dba032fbce64c35c34ff386ce (diff)
downloadupstream-cc665802932f831e790f4f849214a56955458d34.tar.gz
upstream-cc665802932f831e790f4f849214a56955458d34.tar.bz2
upstream-cc665802932f831e790f4f849214a56955458d34.zip
lzo: fix pkgconfig paths
The last commit to this package that added the pkgconfig file did not fix the paths to point to the prefix. This allows packages to find lzo properly. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/lzo/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/libs/lzo/Makefile b/package/libs/lzo/Makefile
index 3ce5f53349..09885e8d9b 100644
--- a/package/libs/lzo/Makefile
+++ b/package/libs/lzo/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lzo
PKG_VERSION:=2.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.oberhumer.com/opensource/lzo/download/
@@ -49,6 +49,8 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/lzo $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lzo2.pc $(1)/usr/lib/pkgconfig
+ $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/lzo2.pc
+ $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/lzo2.pc
endef
define Package/liblzo/install