aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2021-03-19 17:09:26 -0600
committerPaul Spooren <mail@aparcar.org>2021-03-19 13:37:51 -1000
commit7fae64cc065738b73a1dddc2fc28adde36c1ae3d (patch)
tree8cae463499aec7428b5440782ab7c61c5957aeee /package/libs
parentd28880cdd86e10142fd86936f5da188eaeeaf9eb (diff)
downloadupstream-7fae64cc065738b73a1dddc2fc28adde36c1ae3d.tar.gz
upstream-7fae64cc065738b73a1dddc2fc28adde36c1ae3d.tar.bz2
upstream-7fae64cc065738b73a1dddc2fc28adde36c1ae3d.zip
libnfnetlink: quote $(FPIC) on command line
When $(FPIC) gets expanded on the command line (for instance when setting environment variables for libtool, configure, or make) we can't count on it not needing quoting (i.e. it could contain multiple flags separated with spaces). Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libnfnetlink/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libs/libnfnetlink/Makefile b/package/libs/libnfnetlink/Makefile
index 7d65d63857..bc64ff111d 100644
--- a/package/libs/libnfnetlink/Makefile
+++ b/package/libs/libnfnetlink/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libnfnetlink
PKG_VERSION:=1.0.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
@@ -45,7 +45,7 @@ CONFIGURE_ARGS += \
--enable-shared
CONFIGURE_VARS += \
- lt_prog_compiler_pic=$(FPIC)
+ lt_prog_compiler_pic="$(FPIC)"
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/libnfnetlink