aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-09-01 14:50:52 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-09-06 20:30:51 +0200
commit787de4331f0b01da114f16fcfaea5ecdfc010310 (patch)
tree0a373afb9461cc85a81e8128cb3833dcc621f813 /package/libs
parentb71433f42dc6b011599c4925a5663af77224761f (diff)
downloadupstream-787de4331f0b01da114f16fcfaea5ecdfc010310.tar.gz
upstream-787de4331f0b01da114f16fcfaea5ecdfc010310.tar.bz2
upstream-787de4331f0b01da114f16fcfaea5ecdfc010310.zip
wolfssl: Activate link time optimization (LTO)
The ipk sizes for mips_24Kc change like this: old: libwolfssl24_4.5.0-stable-1_mips_24kc.ipk 391.545 new: libwolfssl24_4.5.0-stable-2_mips_24kc.ipk 387.439 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/wolfssl/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/libs/wolfssl/Makefile b/package/libs/wolfssl/Makefile
index 1fcca9fc5f..dc8ca2b262 100644
--- a/package/libs/wolfssl/Makefile
+++ b/package/libs/wolfssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=wolfssl
PKG_VERSION:=4.5.0-stable
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
@@ -56,7 +56,8 @@ define Package/libwolfssl/config
source "$(SOURCE)/Config.in"
endef
-TARGET_CFLAGS += $(FPIC) -DFP_MAX_BITS=8192 -fomit-frame-pointer
+TARGET_CFLAGS += $(FPIC) -DFP_MAX_BITS=8192 -fomit-frame-pointer -flto
+TARGET_LDFLAGS += -flto
# --enable-stunnel needed for OpenSSL API compatibility bits
CONFIGURE_ARGS += \