aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-03-28 22:21:49 -1000
committerPaul Spooren <mail@aparcar.org>2021-03-29 13:47:19 -1000
commit75ea474b9002c758e9a23023f7636258a467704c (patch)
tree986e1a5f347268f8cbfd4f95f7dc78d195acf8be /package/libs
parentbb9915407bdf24fd45daa49b32715fe3e8e00be0 (diff)
downloadupstream-75ea474b9002c758e9a23023f7636258a467704c.tar.gz
upstream-75ea474b9002c758e9a23023f7636258a467704c.tar.bz2
upstream-75ea474b9002c758e9a23023f7636258a467704c.zip
ncurses: split long line of supported terminfo
The terminfo files were all in one row which is terrible to read. Split them over multiple lines to improve readability. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/ncurses/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/package/libs/ncurses/Makefile b/package/libs/ncurses/Makefile
index cc1e960a0c..b42f23fa85 100644
--- a/package/libs/ncurses/Makefile
+++ b/package/libs/ncurses/Makefile
@@ -120,7 +120,18 @@ ifneq ($(HOST_OS),FreeBSD)
mv $$$$dir $$$$(echo -ne "\x$$$$dir"); \
done \
)
- for file in a/ansi d/dumb l/linux r/rxvt r/rxvt-unicode s/screen v/vt100 v/vt102 x/xterm x/xterm-color x/xterm-256color; do \
+ for file in \
+ a/ansi \
+ d/dumb \
+ l/linux \
+ r/rxvt \
+ r/rxvt-unicode \
+ s/screen \
+ v/vt100 \
+ v/vt102 \
+ x/xterm \
+ x/xterm-color \
+ x/xterm-256color; do \
$(INSTALL_DIR) $(1)/usr/share/terminfo/`dirname $$$$file`; \
$(CP) $(PKG_INSTALL_DIR)/usr/share/terminfo/$$$$file \
$(1)/usr/share/terminfo/$$$$file; \