aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-10 01:56:28 -0800
committerPetr Štetiar <ynezz@true.cz>2020-12-22 18:59:10 +0100
commit6e5759f6b4852515a6092a43a767a0f5e09a6cb7 (patch)
tree902b0b66c47c8b6002c9ed1b308cd283dbdc571b /package/libs
parent36540aa973cb87ac92012852eed2a733b9ceb54e (diff)
downloadupstream-6e5759f6b4852515a6092a43a767a0f5e09a6cb7.tar.gz
upstream-6e5759f6b4852515a6092a43a767a0f5e09a6cb7.tar.bz2
upstream-6e5759f6b4852515a6092a43a767a0f5e09a6cb7.zip
pcre: fix paths in config file
The paths are pointing to OS paths, not OpenWrt ones. Use SED line from libpng to fix and adjust accordingly. This may allow certain packages that use the config file to pick up pcre. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/pcre/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/pcre/Makefile b/package/libs/pcre/Makefile
index bf3f733a5c..37d939da7f 100644
--- a/package/libs/pcre/Makefile
+++ b/package/libs/pcre/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pcre
PKG_VERSION:=8.44
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -87,6 +87,7 @@ MAKE_FLAGS += \
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pcre-config $(1)/usr/bin/
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(1)/usr/bin/pcre-config
$(INSTALL_DIR) $(2)/bin
$(LN) $(STAGING_DIR)/usr/bin/pcre-config $(2)/bin