aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-11 19:21:40 -0800
committerPetr Štetiar <ynezz@true.cz>2020-12-22 19:11:50 +0100
commit57fe7d5401e3ef8390a66c907b9e688c74318ded (patch)
tree6aed3c9d0118aa4139f0673d19c71e2aea1421f2 /package/libs
parent95f1002acab574c24ad78f4453f091bf5a6731c7 (diff)
downloadupstream-57fe7d5401e3ef8390a66c907b9e688c74318ded.tar.gz
upstream-57fe7d5401e3ef8390a66c907b9e688c74318ded.tar.bz2
upstream-57fe7d5401e3ef8390a66c907b9e688c74318ded.zip
toolchain: remove uClibc install stuff
This is preparation for removing uClibc-ng. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/toolchain/Makefile31
1 files changed, 3 insertions, 28 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 6853d95997..52a4cda19f 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=toolchain
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=GPL-3.0-with-GCC-exception
@@ -458,11 +458,6 @@ LIBGCC_A=$(lastword $(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc_pic.a))
LIBGCC_MAP=$(lastword $(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc.map))
LIBGCC_SO=$(lastword $(wildcard $(TOOLCHAIN_DIR)/lib/libgcc_s.so.*))
-define Build/Compile/uClibc
- $(CP) \
- $(TOOLCHAIN_DIR)/lib/libuClibc-*.so \
- $(PKG_BUILD_DIR)/
-endef
ifneq ($(LIBGCC_SO),)
define Build/Compile/libgcc
$(CP) $(LIBGCC_SO) $(PKG_BUILD_DIR)/
@@ -535,21 +530,6 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
done
endef
- define Package/uClibc/install
- $(INSTALL_DIR) $(1)/lib
- $(CP) \
- $(TOOLCHAIN_DIR)/lib/ld*-uClibc.so.* \
- $(TOOLCHAIN_DIR)/lib/ld*-uClibc-$(LIBC_SO_VERSION).so \
- $(1)/lib/
- $(CP) \
- $(TOOLCHAIN_DIR)/lib/libc.so.* \
- $(TOOLCHAIN_DIR)/lib/libuClibc-$(LIBC_SO_VERSION).so \
- $(1)/lib/
- $(CP) \
- $(PKG_BUILD_DIR)/libuClibc-* \
- $(1)/lib/
- endef
-
LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/libc.so*)))
define Package/musl/install
@@ -578,7 +558,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/libpthread/install
$(INSTALL_DIR) $(1)/lib
- ifneq ($(CONFIG_USE_MUSL)$(CONFIG_USE_UCLIBC),y)
+ ifneq ($(CONFIG_USE_MUSL),y)
$(CP) \
$(TOOLCHAIN_DIR)/lib/libpthread.so.* \
$(TOOLCHAIN_DIR)/lib/libpthread-$(LIBC_SO_VERSION).so \
@@ -590,11 +570,6 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(INSTALL_DIR) $(1)/lib
$(CP) \
$(TOOLCHAIN_DIR)/lib/libthread_db.so.* $(1)/lib
- ifeq ($(CONFIG_USE_UCLIBC),y)
- $(CP) \
- $(TOOLCHAIN_DIR)/lib/libthread_db-$(LIBC_SO_VERSION).so \
- $(1)/lib/
- endif
endef
define Package/libpthread/install_lib
@@ -603,7 +578,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/librt/install
$(INSTALL_DIR) $(1)/lib
- ifneq ($(CONFIG_USE_MUSL)$(CONFIG_USE_UCLIBC),y)
+ ifneq ($(CONFIG_USE_MUSL),y)
$(CP) \
$(TOOLCHAIN_DIR)/lib/librt.so.* \
$(TOOLCHAIN_DIR)/lib/librt-$(LIBC_SO_VERSION).so \