aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorKonstantin Demin <rockdrilla@gmail.com>2019-06-12 12:10:09 +0300
committerHans Dedecker <dedeckeh@gmail.com>2019-06-12 23:00:58 +0200
commit38b22b1e7022d6b386ce25f39d05cc33fc659240 (patch)
tree1dfd5095c4c375a95db0d8104ceff216ab9fae28 /package/libs
parentc12bd3a21bef7d9795f44be6ed70f6aa301122d7 (diff)
downloadupstream-38b22b1e7022d6b386ce25f39d05cc33fc659240.tar.gz
upstream-38b22b1e7022d6b386ce25f39d05cc33fc659240.tar.bz2
upstream-38b22b1e7022d6b386ce25f39d05cc33fc659240.zip
nghttp2: deduplicate files in libnghttp2
libnghttp2 accidentally ships library twice: $ tar -Oxzf libnghttp2-14_1.38.0-1_mips_24kc.ipk ./data.tar.gz | tar -tzvf - drwxr-xr-x root/root 0 2019-06-07 23:14 ./ drwxr-xr-x root/root 0 2019-06-07 23:14 ./usr/ drwxr-xr-x root/root 0 2019-06-07 23:14 ./usr/lib/ -rw-r--r-- root/root 144412 2019-06-07 23:14 ./usr/lib/libnghttp2.so.14 -rw-r--r-- root/root 144412 2019-06-07 23:14 ./usr/lib/libnghttp2.so.14.17.3 after fix, there's library and symlink (as designed): $ tar -Oxzf libnghttp2-14_1.38.0-2_mips_24kc.ipk ./data.tar.gz | tar -tzvf - drwxr-xr-x root/root 0 2019-06-07 23:14 ./ drwxr-xr-x root/root 0 2019-06-07 23:14 ./usr/ drwxr-xr-x root/root 0 2019-06-07 23:14 ./usr/lib/ lrwxrwxrwx root/root 0 2019-06-07 23:14 ./usr/lib/libnghttp2.so.14 -> libnghttp2.so.14.17.3 -rw-r--r-- root/root 144412 2019-06-07 23:14 ./usr/lib/libnghttp2.so.14.17.3 Binary package size reduced accordingly: 134621 -> 66593. Compile/run-tested: ar71xx/generic. Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/nghttp2/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libs/nghttp2/Makefile b/package/libs/nghttp2/Makefile
index 14a4f728b4..f9dcd3930a 100644
--- a/package/libs/nghttp2/Makefile
+++ b/package/libs/nghttp2/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nghttp2
PKG_VERSION:=1.38.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/nghttp2/nghttp2/releases/download/v$(PKG_VERSION)
@@ -40,7 +40,7 @@ endef
define Package/libnghttp2/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libnghttp2.so.* $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnghttp2.so.* $(1)/usr/lib
endef
$(eval $(call BuildPackage,libnghttp2))