aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-02-15 00:28:35 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-02-15 01:15:49 +0100
commit304df2836a2c02a5f63df64d8b23100d6baaa3d3 (patch)
tree4f1f7d10fc5e2739e1baf31670f9d327833398da /package/libs
parent505a808302f0a7bf8a0da77981532d7274360edd (diff)
downloadupstream-304df2836a2c02a5f63df64d8b23100d6baaa3d3.tar.gz
upstream-304df2836a2c02a5f63df64d8b23100d6baaa3d3.tar.bz2
upstream-304df2836a2c02a5f63df64d8b23100d6baaa3d3.zip
Revert "wolfssl: use dynamic ABI_VERSION depending on the configuration and package version"
This fixes the build on MIPS BE like ath25 and ath79 target. We get this error message when linking libwolfssl: mips-openwrt-linux-musl/bin/ld: /home/hauke/openwrt/openwrt/staging_dir/target-mips_mips32_musl/usr/lib/libwolfssl.so: unknown type [0x7000002a] section `.MIPS.abiflags' mips-openwrt-linux-musl/bin/ld: /home/hauke/openwrt/openwrt/staging_dir/target-mips_mips32_musl/usr/lib/libwolfssl.so: unknown type [0x7000002a] section `.MIPS.abiflags' mips-openwrt-linux-musl/bin/ld: skipping incompatible /home/hauke/openwrt/openwrt/staging_dir/target-mips_mips32_musl/usr/lib/libwolfssl.so when searching for -lwolfssl mips-openwrt-linux-musl/bin/ld: cannot find -lwolfssl collect2: error: ld returned 1 exit status This reverts commit 2591c83b3406c16d3c1cd2dc7fa59c3c1b901d3c. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/wolfssl/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/libs/wolfssl/Makefile b/package/libs/wolfssl/Makefile
index 51dc4d5a09..ff01fca663 100644
--- a/package/libs/wolfssl/Makefile
+++ b/package/libs/wolfssl/Makefile
@@ -33,8 +33,6 @@ PKG_CONFIG_DEPENDS:=\
CONFIG_WOLFSSL_HAS_SESSION_TICKET CONFIG_WOLFSSL_HAS_TLSV10 \
CONFIG_WOLFSSL_HAS_TLSV13 CONFIG_WOLFSSL_HAS_WPAS CONFIG_WOLFSSL_HAS_CERTGEN
-PKG_ABI_VERSION=$(patsubst %-stable,%,$(PKG_VERSION)).$(call version_abbrev,$(call confvar,$(PKG_CONFIG_DEPENDS)))
-
include $(INCLUDE_DIR)/package.mk
define Package/libwolfssl
@@ -46,7 +44,7 @@ define Package/libwolfssl
MENU:=1
PROVIDES:=libcyassl
DEPENDS:=+WOLFSSL_HAS_DEVCRYPTO:kmod-cryptodev +WOLFSSL_HAS_AFALG:kmod-crypto-user
- ABI_VERSION:=$(PKG_ABI_VERSION)
+ ABI_VERSION:=24
endef
define Package/libwolfssl/description