aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-28 10:19:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-28 10:19:26 +0000
commit2d13d8dc767142e4b75aabd9264e2749518b1d28 (patch)
tree0097293029d564894f98ef72d7b8e910a3371df6 /package/libs
parent5441f566859a350f970d5aad510b950ee6d9f502 (diff)
downloadupstream-2d13d8dc767142e4b75aabd9264e2749518b1d28.tar.gz
upstream-2d13d8dc767142e4b75aabd9264e2749518b1d28.tar.bz2
upstream-2d13d8dc767142e4b75aabd9264e2749518b1d28.zip
conntrack-tools: update package (along with associated libraries) to the latest version, fix musl build issues
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45077
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libnetfilter-cthelper/Makefile71
-rw-r--r--package/libs/libnetfilter-cttimeout/Makefile71
-rw-r--r--package/libs/libnetfilter-queue/Makefile71
-rw-r--r--package/libs/libnfnetlink/patches/100-missing_include.patch10
4 files changed, 223 insertions, 0 deletions
diff --git a/package/libs/libnetfilter-cthelper/Makefile b/package/libs/libnetfilter-cthelper/Makefile
new file mode 100644
index 0000000000..84a77645bd
--- /dev/null
+++ b/package/libs/libnetfilter-cthelper/Makefile
@@ -0,0 +1,71 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnetfilter_cthelper
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+ http://www.netfilter.org/projects/libnetfilter_cthelper/files/ \
+ ftp://ftp.netfilter.org/pub/libnetfilter_cthelper/
+PKG_MD5SUM:=b2efab1a3a198a5add448960ba011acd
+
+PKG_FIXUP:=autoreconf
+PKG_LICENSE:=GPL-2.0+
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnetfilter-cthelper
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libmnl
+ TITLE:=API to the in-kernel connection tracking helper infrastructure
+ URL:=http://www.netfilter.org/projects/libnetfilter_cthelper/
+endef
+
+define Package/libnetfilter-cthelper/description
+ libnetfilter_cthelper is a userspace library providing a programming
+ interface (API) to the in-kernel connection tracking helpers.
+ This library is currently used by conntrack-tools.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-static \
+ --enable-shared \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/libnetfilter_cthelper
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/libnetfilter_cthelper/*.h \
+ $(1)/usr/include/libnetfilter_cthelper/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_cthelper.{so*,a,la} \
+ $(1)/usr/lib/
+
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnetfilter_cthelper.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libnetfilter-cthelper/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_cthelper.so.* \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnetfilter-cthelper))
diff --git a/package/libs/libnetfilter-cttimeout/Makefile b/package/libs/libnetfilter-cttimeout/Makefile
new file mode 100644
index 0000000000..d065d2631b
--- /dev/null
+++ b/package/libs/libnetfilter-cttimeout/Makefile
@@ -0,0 +1,71 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnetfilter_cttimeout
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+ http://www.netfilter.org/projects/libnetfilter_cttimeout/files/ \
+ ftp://ftp.netfilter.org/pub/libnetfilter_cttimeout/
+PKG_MD5SUM:=7697437fc9ebb6f6b83df56a633db7f9
+
+PKG_FIXUP:=autoreconf
+PKG_LICENSE:=GPL-2.0+
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnetfilter-cttimeout
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libmnl
+ TITLE:=API to the in-kernel connection tracking timeout infrastructure
+ URL:=http://www.netfilter.org/projects/libnetfilter_cttimeout/
+endef
+
+define Package/libnetfilter-cttimeout/description
+ libnetfilter_cttimeout is a userspace library providing a programming
+ interface (API) to the in-kernel connection tracking timeout handling.
+ This library is currently used by conntrack-tools.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-static \
+ --enable-shared \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/libnetfilter_cttimeout
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/libnetfilter_cttimeout/*.h \
+ $(1)/usr/include/libnetfilter_cttimeout/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_cttimeout.{so*,a,la} \
+ $(1)/usr/lib/
+
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnetfilter_cttimeout.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libnetfilter-cttimeout/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_cttimeout.so.* \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnetfilter-cttimeout))
diff --git a/package/libs/libnetfilter-queue/Makefile b/package/libs/libnetfilter-queue/Makefile
new file mode 100644
index 0000000000..6502e917d1
--- /dev/null
+++ b/package/libs/libnetfilter-queue/Makefile
@@ -0,0 +1,71 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnetfilter_queue
+PKG_VERSION:=1.0.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+ http://www.netfilter.org/projects/libnetfilter_queue/files/ \
+ ftp://ftp.netfilter.org/pub/libnetfilter_queue/
+PKG_MD5SUM:=df09befac35cb215865b39a36c96a3fa
+
+PKG_FIXUP:=autoreconf
+PKG_LICENSE:=GPL-2.0+
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnetfilter-queue
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libmnl +libnfnetlink
+ TITLE:=API to the in-kernel connection tracking queue infrastructure
+ URL:=http://www.netfilter.org/projects/libnetfilter_queue/
+endef
+
+define Package/libnetfilter-queue/description
+ libnetfilter_queue is a userspace library providing a programming
+ interface (API) to the in-kernel connection tracking state table.
+ This library is currently used by conntrack-tools.
+endef
+
+TARGET_CFLAGS += $(FPIC) -D_GNU_SOURCE=1
+
+CONFIGURE_ARGS += \
+ --enable-static \
+ --enable-shared \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/libnetfilter_queue
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/libnetfilter_queue/*.h \
+ $(1)/usr/include/libnetfilter_queue/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_queue.{so*,a,la} \
+ $(1)/usr/lib/
+
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnetfilter_queue.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libnetfilter-queue/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnetfilter_queue.so.* \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnetfilter-queue))
diff --git a/package/libs/libnfnetlink/patches/100-missing_include.patch b/package/libs/libnfnetlink/patches/100-missing_include.patch
index 68155c3005..163307d895 100644
--- a/package/libs/libnfnetlink/patches/100-missing_include.patch
+++ b/package/libs/libnfnetlink/patches/100-missing_include.patch
@@ -8,3 +8,13 @@
#include <sys/socket.h> /* for sa_family_t */
#include <linux/netlink.h>
#include <libnfnetlink/linux_nfnetlink.h>
+--- a/include/libnfnetlink/linux_nfnetlink.h
++++ b/include/libnfnetlink/linux_nfnetlink.h
+@@ -1,6 +1,6 @@
+ #ifndef _NFNETLINK_H
+ #define _NFNETLINK_H
+-#include <linux/types.h>
++#include <sys/types.h>
+ #include <libnfnetlink/linux_nfnetlink_compat.h>
+
+ enum nfnetlink_groups {