aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-14 17:56:17 -0800
committerPetr Štetiar <ynezz@true.cz>2020-12-22 18:59:10 +0100
commit2a92754ce92e8e360f3a452ffbe738f6f8957290 (patch)
tree728cf5c0f10a8142bb414664a57973e7150b88ae /package/libs
parentbc3edae488bea4219f99782b9b22753897b3c51d (diff)
downloadupstream-2a92754ce92e8e360f3a452ffbe738f6f8957290.tar.gz
upstream-2a92754ce92e8e360f3a452ffbe738f6f8957290.tar.bz2
upstream-2a92754ce92e8e360f3a452ffbe738f6f8957290.zip
libpcap: fix pcap-config
pcap-config as installed is using OS paths instead of OpenWrt ones. Take fix from libpng and adjust as needed. This problem seems to occur on Arch Linux and not on Debian/Fedora based distros. No idea why. Remove CMAKE_INSTALL as there is now an InstallDev section. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libpcap/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/package/libs/libpcap/Makefile b/package/libs/libpcap/Makefile
index 1a2cdcdd98..35ceb18c29 100644
--- a/package/libs/libpcap/Makefile
+++ b/package/libs/libpcap/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libpcap
PKG_VERSION:=1.9.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.us.tcpdump.org/release/ \
@@ -18,7 +18,6 @@ PKG_HASH:=635237637c5b619bcceba91900666b64d56ecb7be63f298f601ec786ce087094
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
-CMAKE_INSTALL:=1
PKG_ASLR_PIE_REGULAR:=1
PKG_BUILD_PARALLEL:=1
@@ -71,6 +70,15 @@ CMAKE_OPTIONS += $(if $(CONFIG_PCAP_HAS_NETFILTER) ,,-DPCAP_SUPPORT_NETFILTER=OF
CMAKE_OPTIONS += $(if $(CONFIG_IPV6),-DINET6=ON,-DINET6=OFF)
+define Build/InstallDev
+ $(call Build/InstallDev/cmake,$(1))
+ $(SED) \
+ 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+ $(1)/usr/bin/pcap-config
+ $(INSTALL_DIR) $(2)/bin
+ $(LN) ../../usr/bin/pcap-config $(2)/bin/pcap-config
+endef
+
define Package/libpcap/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcap.so.* $(1)/usr/lib/