aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-01-26 14:37:04 -0800
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2021-03-13 21:33:22 +0000
commit29e2be69c4689f3438340f23a6eb5649516f0c6d (patch)
treeb12c86b4c3bf51234e0bd3d6fd0f983052cc2ca6 /package/libs
parentc1f3c52564fdec85394e7c338f56df0943ce8b10 (diff)
downloadupstream-29e2be69c4689f3438340f23a6eb5649516f0c6d.tar.gz
upstream-29e2be69c4689f3438340f23a6eb5649516f0c6d.tar.bz2
upstream-29e2be69c4689f3438340f23a6eb5649516f0c6d.zip
elfutils: remove host build from target package
Commit f4da28c301 ("elfutils: Add host build") supplied a libelf host library to fix a glib2 host build error, but this need was later removed by b6212c8769 ("glib2: don't use libelf during host build"). More importantly, there are already two sources for libelf host libraries: OpenWRT build prerequisites [1] and tools/libelf. A third is not needed. Ref [1]: https://openwrt.org/docs/guide-developer/build-system/install-buildsystem#prerequisites Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/elfutils/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index aa6743e688..dd0b8ecdde 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -25,7 +25,6 @@ PKG_USE_MIPS16:=0
PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/nls.mk
define Package/elfutils/Default
@@ -99,4 +98,3 @@ endef
$(eval $(call BuildPackage,libelf))
$(eval $(call BuildPackage,libdw))
$(eval $(call BuildPackage,libasm))
-$(eval $(call HostBuild))