aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-10-31 00:06:53 +0000
committerDaniel Golle <daniel@makrotopia.org>2020-10-31 00:49:43 +0000
commit237f708b3c5f6e4f92c8a892fe2cbb3d22df8e9f (patch)
tree2fe94dc07a63506f904e0a0914a367da5dffa1e9 /package/libs
parent2aa558c49a12c0820fd7b6cc55bf90b320ef3551 (diff)
downloadupstream-237f708b3c5f6e4f92c8a892fe2cbb3d22df8e9f.tar.gz
upstream-237f708b3c5f6e4f92c8a892fe2cbb3d22df8e9f.tar.bz2
upstream-237f708b3c5f6e4f92c8a892fe2cbb3d22df8e9f.zip
libselinux: remove dependency on musl-fts for non-musl builds
Suggested-by: Curtis Deptuck <curtdept@users.noreply.github.com> Tested-by: Curtis Deptuck <curtdept@users.noreply.github.com> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libselinux/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/package/libs/libselinux/Makefile b/package/libs/libselinux/Makefile
index 20d9225d39..5fe745d004 100644
--- a/package/libs/libselinux/Makefile
+++ b/package/libs/libselinux/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libselinux
PKG_VERSION:=3.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
@@ -69,7 +69,7 @@ define Package/libselinux
$(call Package/libselinux/Default)
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libsepol +libpcre +musl-fts
+ DEPENDS:=+libsepol +libpcre +USE_MUSL:musl-fts
endef
define Package/libselinux/description
@@ -109,8 +109,11 @@ HOST_MAKE_FLAGS += \
PREFIX=$(STAGING_DIR_HOSTPKG) \
SHLIBDIR=$(STAGING_DIR_HOSTPKG)/lib
+ifeq ($(CONFIG_USE_MUSL),y)
+MAKE_FLAGS += FTS_LDLIBS=-lfts
+endif
+
MAKE_FLAGS += \
- FTS_LDLIBS=-lfts \
SHLIBDIR=/usr/lib \
OS=Linux