aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-05-22 16:16:47 -0700
committerPetr Štetiar <ynezz@true.cz>2020-06-03 16:49:28 +0200
commit173d2843c7d9a8007e3d2874b1f3bb909df6c95a (patch)
tree53eaf0e1eacd3a4f602bc4da82c9b2080ea4373f /package/libs
parent0b3e1205df64f14a7a06d354abc574cb59cad0c3 (diff)
downloadupstream-173d2843c7d9a8007e3d2874b1f3bb909df6c95a.tar.gz
upstream-173d2843c7d9a8007e3d2874b1f3bb909df6c95a.tar.bz2
upstream-173d2843c7d9a8007e3d2874b1f3bb909df6c95a.zip
libconfig: move into packages feed
No package in base uses libconfig. Everything is in the packages feed. Ref: https://github.com/openwrt/packages/pull/12255 Signed-off-by: Rosen Penev <rosenp@gmail.com> [subject facelift, PR ref] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libconfig/Makefile60
1 files changed, 0 insertions, 60 deletions
diff --git a/package/libs/libconfig/Makefile b/package/libs/libconfig/Makefile
deleted file mode 100644
index 39fcddf082..0000000000
--- a/package/libs/libconfig/Makefile
+++ /dev/null
@@ -1,60 +0,0 @@
-#
-# Copyright (C) 2008-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libconfig
-PKG_VERSION:=1.7.2
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://hyperrealm.github.io/libconfig/dist/
-PKG_HASH:=7c3c7a9c73ff3302084386e96f903eb62ce06953bb1666235fac74363a16fad9
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
-PKG_LICENSE:=LGPL-2.1+
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libconfig
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=Configuration File Library
- URL:=http://www.hyperrealm.com/libconfig/
- ABI_VERSION:=11
-endef
-
-define Package/libconfig/description
- Libconfig is a simple library for manipulating structured configuration
- files. This file format is more compact and more readable than XML. And
- unlike XML, it is type-aware, so it is not necessary to do string
- parsing in application code.
-
- Libconfig is very compact -- just 38K for the stripped C shared
- library (less than one-fourth the size of the expat XML parser library)
- and 66K for the stripped C++ shared library. This makes it well-suited
- for memory-constrained systems like handheld devices.
-endef
-
-CONFIGURE_ARGS += \
- --enable-shared \
- --disable-static \
- --disable-cxx
-
-define Build/InstallDev
- $(CP) $(PKG_INSTALL_DIR)/* $(1)/
-endef
-
-define Package/libconfig/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfig.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libconfig))