aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-11 11:26:14 -0700
committerPetr Štetiar <ynezz@true.cz>2020-12-22 18:59:10 +0100
commit0d502293e6061d99184a42ea728966f1432b6233 (patch)
tree286c05121378977ec2527fe8f895252c98b0a93b /package/libs
parentc0e6b785f00737a767113c728a6cf4f3838ef9a2 (diff)
downloadupstream-0d502293e6061d99184a42ea728966f1432b6233.tar.gz
upstream-0d502293e6061d99184a42ea728966f1432b6233.tar.bz2
upstream-0d502293e6061d99184a42ea728966f1432b6233.zip
elfutils: update to 0.180
Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/elfutils/Makefile4
-rw-r--r--package/libs/elfutils/patches/100-musl-compat.patch2
-rw-r--r--package/libs/elfutils/patches/110-no-cdefs.patch6
3 files changed, 6 insertions, 6 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index e6868c56f4..f2b25d2c36 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
-PKG_VERSION:=0.179
+PKG_VERSION:=0.180
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
-PKG_HASH:=25a545566cbacaa37ae6222e58f1c48ea4570f53ba991886e2f5ce96e22a23a2
+PKG_HASH:=b827b6e35c59d188ba97d7cf148fa8dc6f5c68eb6c5981888dfdbb758c0b569d
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=GPL-3.0-or-later
diff --git a/package/libs/elfutils/patches/100-musl-compat.patch b/package/libs/elfutils/patches/100-musl-compat.patch
index 374e832d3f..508ff9e946 100644
--- a/package/libs/elfutils/patches/100-musl-compat.patch
+++ b/package/libs/elfutils/patches/100-musl-compat.patch
@@ -24,7 +24,7 @@ https://sourceware.org/bugzilla/show_bug.cgi?id=21002
#include <sys/param.h>
--- a/libdw/libdw_alloc.c
+++ b/libdw/libdw_alloc.c
-@@ -147,5 +147,5 @@ __attribute ((noreturn)) attribute_hidde
+@@ -152,5 +152,5 @@ __attribute ((noreturn)) attribute_hidde
__libdw_oom (void)
{
while (1)
diff --git a/package/libs/elfutils/patches/110-no-cdefs.patch b/package/libs/elfutils/patches/110-no-cdefs.patch
index a7216c141e..f95625a913 100644
--- a/package/libs/elfutils/patches/110-no-cdefs.patch
+++ b/package/libs/elfutils/patches/110-no-cdefs.patch
@@ -39,9 +39,9 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
/* Standard ELF types. */
-@@ -4007,6 +4007,8 @@ enum
- #define R_NDS32_TLS_TPOFF 102
- #define R_NDS32_TLS_DESC 119
+@@ -4103,6 +4103,8 @@ enum
+ #define R_ARC_TLS_LE_S9 0x4a
+ #define R_ARC_TLS_LE_32 0x4b
-__END_DECLS
+#ifdef __cplusplus