aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/zlib
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-05-15 22:30:24 +0800
committerPetr Štetiar <ynezz@true.cz>2019-05-17 21:41:43 +0200
commit782eda9750e5f0d2bda103e1fbe5154032e85822 (patch)
tree8c4dcb63a03f43d72358e4baf22fc04f57a1be46 /package/libs/zlib
parent3fcb70927597bad2896c6b39b2bdd2bb4c371bf3 (diff)
downloadupstream-782eda9750e5f0d2bda103e1fbe5154032e85822.tar.gz
upstream-782eda9750e5f0d2bda103e1fbe5154032e85822.tar.bz2
upstream-782eda9750e5f0d2bda103e1fbe5154032e85822.zip
zlib: Use relative paths in pkg-config metadata file
The buildroot pkg-config (in staging_dir/host/bin) overrides the prefix and exec_prefix variables in *.pc files, to supply the correct (buildroot) paths for callers. If other variables are not defined relative to prefix and exec_prefix, then the returned values will be incorrect. The default zlib.pc file generated by cmake contains absolute paths. This patches the file to use relative paths (relative to ${prefix} and ${exec_prefix}). Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'package/libs/zlib')
-rw-r--r--package/libs/zlib/Makefile2
-rw-r--r--package/libs/zlib/patches/004-relative-pkg-config-paths.patch14
2 files changed, 15 insertions, 1 deletions
diff --git a/package/libs/zlib/Makefile b/package/libs/zlib/Makefile
index 4a2a0e53b0..c7a8415c79 100644
--- a/package/libs/zlib/Makefile
+++ b/package/libs/zlib/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zlib
PKG_VERSION:=1.2.11
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/libpng http://www.zlib.net
diff --git a/package/libs/zlib/patches/004-relative-pkg-config-paths.patch b/package/libs/zlib/patches/004-relative-pkg-config-paths.patch
new file mode 100644
index 0000000000..c86d19b412
--- /dev/null
+++ b/package/libs/zlib/patches/004-relative-pkg-config-paths.patch
@@ -0,0 +1,14 @@
+--- a/zlib.pc.cmakein
++++ b/zlib.pc.cmakein
+@@ -1,8 +1,8 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=@CMAKE_INSTALL_PREFIX@
+-libdir=@INSTALL_LIB_DIR@
+-sharedlibdir=@INSTALL_LIB_DIR@
+-includedir=@INSTALL_INC_DIR@
++libdir=${exec_prefix}/lib
++sharedlibdir=${exec_prefix}/lib
++includedir=${prefix}/include
+
+ Name: zlib
+ Description: zlib compression library